summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/ddrescue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/ddrescue')
-rw-r--r--sys-fs/ddrescue/Manifest3
-rw-r--r--sys-fs/ddrescue/ddrescue-1.16.ebuild40
-rw-r--r--sys-fs/ddrescue/ddrescue-1.18.1.ebuild42
-rw-r--r--sys-fs/ddrescue/ddrescue-1.19.ebuild43
-rw-r--r--sys-fs/ddrescue/metadata.xml8
5 files changed, 136 insertions, 0 deletions
diff --git a/sys-fs/ddrescue/Manifest b/sys-fs/ddrescue/Manifest
new file mode 100644
index 000000000000..7deb7cc43712
--- /dev/null
+++ b/sys-fs/ddrescue/Manifest
@@ -0,0 +1,3 @@
+DIST ddrescue-1.16.tar.gz 104691 SHA256 76b3f2e5fb0306d24f2632c3e168cccb73dc0a348e3a7089cd9230748ff23de6 SHA512 c775ac34701b63ab7efd0a56cecf5c8b198874239e48383142db0ccb83c193c7101335374dc89efaa815b466258181f458a3589ea4abb230804b553fb42b345d WHIRLPOOL 63361744b8640241c59da06d1404b227d88008881a4360e52b654f4137cbef88b0b4e69118bd17a27dd887cf7a820b9cfcc5604ee226e0d57afd1b6d0ebf96c4
+DIST ddrescue-1.18.1.tar.lz 72233 SHA256 58614b4fd32706bd8cd3664349ca9fd0c0488b27a211d829d29e27e4978ba1a9 SHA512 66493da18f0c0cab5ad692ede2debad2376aeec53b23f96c5063d21da362f724370e785bfe38f5495bc57971d5ed428c6da8155b4eafd7d07a94e5a4d0955c96 WHIRLPOOL ec669a3905f6bac77e998e1cfdb609158141d0e53f9a2998662888253c4523f56e8d203af316d79e57b634ef198ef2acc48cb9d161468bdb86c53d301d9f9e84
+DIST ddrescue-1.19.tar.lz 68354 SHA256 ed8d0c9d9aac80a9110e9cb0d0a91a7390d3bf9f816b67a62ca4eb140f4747b8 SHA512 e95aab2f07b6759b8846ad2866cb763096d81655fb6fb8a718b5b4842eee4d834162817cbde830d2f7bb5dbbd1509a0d794389462c00679b18b63608ec180984 WHIRLPOOL 20cef1400876355dae7255b8075a026e115ed0f3cc35736b44838850716357aa33b8fc23bce97207b20c13ffe2af2e65be6c434c63814910bf04798788f47f06
diff --git a/sys-fs/ddrescue/ddrescue-1.16.ebuild b/sys-fs/ddrescue/ddrescue-1.16.ebuild
new file mode 100644
index 000000000000..ae6a1f54b24f
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.16.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
+HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86 ~amd64-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ # not a normal configure script
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man
+ dodoc ChangeLog README NEWS AUTHORS
+}
diff --git a/sys-fs/ddrescue/ddrescue-1.18.1.ebuild b/sys-fs/ddrescue/ddrescue-1.18.1.ebuild
new file mode 100644
index 000000000000..9564ee28e54c
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.18.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic unpacker
+
+DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
+HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86 ~amd64-linux"
+IUSE="static"
+
+DEPEND="$(unpacker_src_uri_depends)"
+RDEPEND=""
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # not a normal configure script
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man
+ dodoc ChangeLog README NEWS AUTHORS
+}
diff --git a/sys-fs/ddrescue/ddrescue-1.19.ebuild b/sys-fs/ddrescue/ddrescue-1.19.ebuild
new file mode 100644
index 000000000000..1b57e60e6303
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.19.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic unpacker
+
+DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
+HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="static"
+
+DEPEND="$(unpacker_src_uri_depends)"
+RDEPEND=""
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # not a normal configure script
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ --enable-linux \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man
+ dodoc ChangeLog README NEWS AUTHORS
+}
diff --git a/sys-fs/ddrescue/metadata.xml b/sys-fs/ddrescue/metadata.xml
new file mode 100644
index 000000000000..91c8a805afc2
--- /dev/null
+++ b/sys-fs/ddrescue/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+</pkgmetadata>