summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-28 02:47:53 -0400
committerSam James <sam@gentoo.org>2024-03-29 02:28:25 +0000
commit8a06e29b72c23a556efa9cd44ca232bf9d3f16e5 (patch)
tree0208768e41209e67ab2626249ee94426b7b8dff5 /sys-cluster
parentsys-cluster/legion: use the literal repository name in urls (diff)
downloadgentoo-8a06e29b72c23a556efa9cd44ca232bf9d3f16e5.tar.gz
gentoo-8a06e29b72c23a556efa9cd44ca232bf9d3f16e5.tar.bz2
gentoo-8a06e29b72c23a556efa9cd44ca232bf9d3f16e5.zip
sys-cluster/legion: mark as LTO-unsafe
Intentionally omitted from live ebuild since it works in git master. Closes: https://bugs.gentoo.org/863731 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/legion/legion-21.09.0-r1.ebuild7
-rw-r--r--sys-cluster/legion/legion-23.03.0.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/sys-cluster/legion/legion-21.09.0-r1.ebuild b/sys-cluster/legion/legion-21.09.0-r1.ebuild
index 188222290cd2..de37914d7dbb 100644
--- a/sys-cluster/legion/legion-21.09.0-r1.ebuild
+++ b/sys-cluster/legion/legion-21.09.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="A data-centric parallel programming system"
HOMEPAGE="https://legion.stanford.edu/"
@@ -29,6 +29,11 @@ DEPEND="examples? ( virtual/mpi[cxx] )
RDEPEND="${DEPEND}"
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/863731
+ # Fixed upstream / in live ebuild.
+ filter-lto
+
local mycmakeargs=(
-DLegion_USE_HWLOC=$(usex hwloc)
-DLegion_USE_GASNet=$(usex gasnet)
diff --git a/sys-cluster/legion/legion-23.03.0.ebuild b/sys-cluster/legion/legion-23.03.0.ebuild
index eba0f71162d1..55259ad9c9a6 100644
--- a/sys-cluster/legion/legion-23.03.0.ebuild
+++ b/sys-cluster/legion/legion-23.03.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="A data-centric parallel programming system"
HOMEPAGE="https://legion.stanford.edu/"
@@ -34,6 +34,11 @@ PATCHES=(
)
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/863731
+ # Fixed upstream / in live ebuild.
+ filter-lto
+
local mycmakeargs=(
-DLegion_USE_HWLOC=$(usex hwloc)
-DLegion_USE_GASNet=$(usex gasnet)