summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-28 02:43:22 -0400
committerSam James <sam@gentoo.org>2024-03-29 02:28:25 +0000
commit551342e947332aa9abf2fec4b9a3b8009abbce4a (patch)
treec38ec8b4aeac5ce73748326b187913770e5028c2 /sys-cluster
parentsys-cluster/legion: remove conceptually invalid repository clone url (diff)
downloadgentoo-551342e947332aa9abf2fec4b9a3b8009abbce4a.tar.gz
gentoo-551342e947332aa9abf2fec4b9a3b8009abbce4a.tar.bz2
gentoo-551342e947332aa9abf2fec4b9a3b8009abbce4a.zip
sys-cluster/legion: use the literal repository name in urls
It is considered bad style in ::gentoo to use variable replacements in url fields, since it prevents copy/pasting from the file without first running a bash parser. It's okay for tarball name and for the version, but this was the repository base url Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/legion/legion-21.09.0-r1.ebuild6
-rw-r--r--sys-cluster/legion/legion-23.03.0.ebuild6
-rw-r--r--sys-cluster/legion/legion-9999.ebuild4
3 files changed, 8 insertions, 8 deletions
diff --git a/sys-cluster/legion/legion-21.09.0-r1.ebuild b/sys-cluster/legion/legion-21.09.0-r1.ebuild
index 8a7849ea2d4e..188222290cd2 100644
--- a/sys-cluster/legion/legion-21.09.0-r1.ebuild
+++ b/sys-cluster/legion/legion-21.09.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,9 +9,9 @@ DESCRIPTION="A data-centric parallel programming system"
HOMEPAGE="https://legion.stanford.edu/"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/StanfordLegion/${PN}.git"
+ EGIT_REPO_URI="https://github.com/StanfordLegion/legion.git"
else
- SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ SRC_URI="https://github.com/StanfordLegion/legion/archive/${P}.tar.gz"
S="${WORKDIR}"/${PN}-${P}
KEYWORDS="~amd64"
diff --git a/sys-cluster/legion/legion-23.03.0.ebuild b/sys-cluster/legion/legion-23.03.0.ebuild
index bc099c90fc81..eba0f71162d1 100644
--- a/sys-cluster/legion/legion-23.03.0.ebuild
+++ b/sys-cluster/legion/legion-23.03.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,9 +9,9 @@ DESCRIPTION="A data-centric parallel programming system"
HOMEPAGE="https://legion.stanford.edu/"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/StanfordLegion/${PN}.git"
+ EGIT_REPO_URI="https://github.com/StanfordLegion/legion.git"
else
- SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ SRC_URI="https://github.com/StanfordLegion/legion/archive/${P}.tar.gz"
S="${WORKDIR}"/${PN}-${P}
KEYWORDS="~amd64"
diff --git a/sys-cluster/legion/legion-9999.ebuild b/sys-cluster/legion/legion-9999.ebuild
index 0857561f4b4a..188222290cd2 100644
--- a/sys-cluster/legion/legion-9999.ebuild
+++ b/sys-cluster/legion/legion-9999.ebuild
@@ -9,9 +9,9 @@ DESCRIPTION="A data-centric parallel programming system"
HOMEPAGE="https://legion.stanford.edu/"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/StanfordLegion/${PN}.git"
+ EGIT_REPO_URI="https://github.com/StanfordLegion/legion.git"
else
- SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ SRC_URI="https://github.com/StanfordLegion/legion/archive/${P}.tar.gz"
S="${WORKDIR}"/${PN}-${P}
KEYWORDS="~amd64"