summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-07-08 14:25:11 -0400
committerMike Gilbert <floppym@gentoo.org>2019-07-08 19:36:24 -0400
commita2cc45b4f4161260a9a5e956c52b3cd4ae889c92 (patch)
tree04a10a85aa049f2362b3f7e0cbb5674717fc0df5 /sys-boot
parentvirtual/cargo: bump to 1.36.0 (diff)
downloadgentoo-a2cc45b4f4161260a9a5e956c52b3cd4ae889c92.tar.gz
gentoo-a2cc45b4f4161260a9a5e956c52b3cd4ae889c92.tar.bz2
gentoo-a2cc45b4f4161260a9a5e956c52b3cd4ae889c92.zip
sys-boot/grub: drop 'static' use flag
Closes: https://bugs.gentoo.org/566632 Package-Manager: Portage-2.3.68, Repoman-2.3.16_p2 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-9999.ebuild19
1 files changed, 3 insertions, 16 deletions
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 5970936ad665..b169b758922e 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -52,7 +52,7 @@ HOMEPAGE="https://www.gnu.org/software/grub/"
# Includes licenses for dejavu and unifont
LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
SLOT="2/${PVR}"
-IUSE="device-mapper doc efiemu +fonts mount nls static sdl test +themes truetype libzfs"
+IUSE="device-mapper doc efiemu +fonts mount nls sdl test +themes truetype libzfs"
GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
@@ -92,7 +92,7 @@ BDEPEND="
)
truetype? ( virtual/pkgconfig )
"
-COMMON_DEPEND="
+DEPEND="
app-arch/xz-utils
>=sys-libs/ncurses-5.2-r5:0=
sdl? ( media-libs/libsdl )
@@ -105,18 +105,7 @@ COMMON_DEPEND="
grub_platforms_xen? ( app-emulation/xen-tools:= )
grub_platforms_xen-32? ( app-emulation/xen-tools:= )
"
-DEPEND="${COMMON_DEPEND}
- static? (
- app-arch/xz-utils[static-libs(+)]
- truetype? (
- app-arch/bzip2[static-libs(+)]
- media-libs/freetype[static-libs(+)]
- sys-libs/zlib[static-libs(+)]
- virtual/pkgconfig
- )
- )
-"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="${DEPEND}
kernel_linux? (
grub_platforms_efi-32? ( sys-boot/efibootmgr )
grub_platforms_efi-64? ( sys-boot/efibootmgr )
@@ -245,8 +234,6 @@ src_configure() {
export HOST_LDFLAGS=${LDFLAGS}
unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
- use static && HOST_LDFLAGS+=" -static"
-
tc-ld-disable-gold #439082 #466536 #526348
export TARGET_LDFLAGS="${TARGET_LDFLAGS} ${LDFLAGS}"
unset LDFLAGS