summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-09-27 01:07:09 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-27 01:08:16 +0200
commit38e7309034b832efb905015626d85162432e93be (patch)
tree100c1935bb26c9aff995e44ed3198698700c5296 /sys-block
parentwww-client/dillo: EAPI7 and improve ebuild. (diff)
downloadgentoo-38e7309034b832efb905015626d85162432e93be.tar.gz
gentoo-38e7309034b832efb905015626d85162432e93be.tar.bz2
gentoo-38e7309034b832efb905015626d85162432e93be.zip
sys-block/storcli: bump to v007.0709.0000.0000
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/storcli/Manifest1
-rw-r--r--sys-block/storcli/storcli-7.0709.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/sys-block/storcli/Manifest b/sys-block/storcli/Manifest
index 1d5047e6138c..520e13640635 100644
--- a/sys-block/storcli/Manifest
+++ b/sys-block/storcli/Manifest
@@ -6,3 +6,4 @@ DIST storcli-1.23.02.zip 48778476 BLAKE2B 9eded7793e822785dfbd15b6a6fa70e70dc1f4
DIST storcli-1.23.02_readme.txt 201906 BLAKE2B 6dde1f7609d51f3d0b2feec9301a57472e92086fc7f1aecad3b455b03b571fb75e23de75d508c40b78ebab357340d8c14f5529fce3ce9ee6b513f5e80d82ad99 SHA512 9eefe69aee1a65339d2360759ba574f632a21bd3d13ba9d4cb0a86980e652addf5f7d2b650588f659caaa8ee302c48bc27b9f3ad7455e65d34dbcff0a8188e03
DIST storcli-7.0504.zip 40558670 BLAKE2B 3cd54b47b42e5bb8329ccd4b09a6c0863347a04b276fa5dc11acf10ac1124c25b5f60e4171de96c1b8975bfae4cc7408554de933ba8fd5547fbd6e9395710ce8 SHA512 1c5c248a1c19eda5974415a7e1cc10c83bfad0d6e37adbd01ae624316fc1d60628503655c4dd0005a14c79c570177664ea9cdb7330b97daf19808a9513b1311a
DIST storcli-7.0606.zip 36634159 BLAKE2B 56cae14537872ef23d8ddc6a0790b727abdf4abecd06b9d1615dc4ad0a554a48bdd077772181d2f0ad9bbe90f015130b4a62caa16b1f02d042403cb6ca389e04 SHA512 ef8bc6b275bb915707624d73d802e84e7a04da087d275055916f047f16d15f1303047c9eb53eae8de88da97ce82fc79616822888fc320af7ba54ad6aa2999996
+DIST storcli-7.0709.zip 25844769 BLAKE2B f44791d0813f348068a89a14a0ea457667ab8e224da09a458bfd1126f5e1d9f19655f5392a8d2a8a04ae07f76fc3c91abcdbd48a058c8e9d517c504de8688e66 SHA512 c3995110b592bbf6e58a0e54f62ddbdbb025c6d27ce56111a40d9eb04b7d5ee7a9bfc76e449b0b4900e1082f20df8e06a852a3fe0efc1114158d104036f6033e
diff --git a/sys-block/storcli/storcli-7.0709.ebuild b/sys-block/storcli/storcli-7.0709.ebuild
new file mode 100644
index 000000000000..0cdb4e15b173
--- /dev/null
+++ b/sys-block/storcli/storcli-7.0709.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit pax-utils
+
+# Upstream is still using strange version numbers
+MY_PV="007.0709.0000.0000"
+
+DESCRIPTION="MegaRAID StorCLI (successor of the MegaCLI)"
+HOMEPAGE="https://www.broadcom.com/support/download-search?dk=storcli"
+SRC_URI="https://docs.broadcom.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/${MY_PV}_Unified_StorCLI.zip -> ${P}.zip"
+
+LICENSE="Avago LSI BSD"
+SLOT="0/7.7"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+DOCS=( readme.txt license.txt )
+
+MY_STORCLI_BASEDIR="/opt/lsi/storcli"
+
+QA_PRESTRIPPED="${MY_STORCLI_BASEDIR:1}/storcli"
+QA_PREBUILT=${QA_PRESTRIPPED}
+
+src_unpack() {
+ local _src_file
+
+ for _src_file in ${A}; do
+ if [[ ${_src_file} == *.txt ]]; then
+ cp "${DISTDIR}/${_src_file}" "${WORKDIR}" || die "Failed to copy '${_src_file}' to '${WORKDIR}'!"
+ else
+ unpack ${_src_file}
+ fi
+ done
+
+ unpack "${WORKDIR}"/Unified_storcli_all_os.zip
+
+ mv Unified_storcli_all_os/Ubuntu/storcli_*.deb "${WORKDIR}" || die "Failed to move storcli_*.deb"
+
+ # Unpack Ubuntu package which will be our $S content
+ unpack "${WORKDIR}"/storcli_*.deb
+ rm -f storcli_*.deb || die "Failed to cleanup storcli_*.deb package"
+ unpack "${WORKDIR}"/data.tar.gz
+
+ mkdir "${S}" || die "Failed to create '${S}'"
+}
+
+src_prepare() {
+ default
+
+ # Create clean $S
+ mv "${WORKDIR}"/*_StorCLI.txt "${S}"/readme.txt || die "Failed to move *StorCLI.txt to readme.txt"
+ mv "${WORKDIR}"/Unified_storcli_all_os/Linux/license.txt "${S}"/license.txt || die "Failed to move Linux/license.txt"
+ rm -rf "${WORKDIR}"/Unified_stor* || die "Failed to cleanup Unified_storcli* dirs/files"
+ mv "${WORKDIR}"/opt/Mega*/storcli/* "${S}" || die "Failed to move storcli_.deb content to '${S}'"
+ rm -rf "${WORKDIR}"/{opt,control.tar.gz,data.tar.gz,debian-binary} || die "Failed to cleanup no longer needed files"
+}
+
+src_install() {
+ exeinto "${MY_STORCLI_BASEDIR}"
+
+ if use x86; then
+ doexe storcli
+ elif use amd64; then
+ newexe storcli64 storcli
+ fi
+
+ dosym "${MY_STORCLI_BASEDIR}"/storcli /usr/sbin/storcli
+
+ dodoc "${DOCS[@]}"
+
+ pax-mark m "${D%/}${MY_STORCLI_BASEDIR}"/storcli
+}