summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-29 02:40:15 +0100
committerSam James <sam@gentoo.org>2024-08-29 02:40:15 +0100
commit13fff84b5b28506385d889aa843011883355160a (patch)
tree62c0772b267275ceae6618d79c607a2542928093 /sys-apps/logwatch
parentdev-libs/libpipeline: add 1.5.8 (diff)
downloadgentoo-13fff84b5b28506385d889aa843011883355160a.tar.gz
gentoo-13fff84b5b28506385d889aa843011883355160a.tar.bz2
gentoo-13fff84b5b28506385d889aa843011883355160a.zip
sys-apps/logwatch: add 7.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/logwatch')
-rw-r--r--sys-apps/logwatch/Manifest1
-rw-r--r--sys-apps/logwatch/files/logwatch-7.11-openssh-9.8.patch37
-rw-r--r--sys-apps/logwatch/logwatch-7.11.ebuild100
3 files changed, 138 insertions, 0 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index 31260357e110..727a74bfcc0a 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1,2 +1,3 @@
DIST logwatch-7.10.tar.gz 511766 BLAKE2B 66d7cb09f4c73ca55a3bad9eb2e9a46eabdc0da444e5361ddc10e7bee28de2e58f2c10530f75d40b2689d33624d612f439171b995e9f21a7e48bf211db1f2bd2 SHA512 838bcc7a3b12eb31450a20195fe2ca4ab238500051bb2f50bd1775272fefa412e0a2473c0294a5495ef594fa530b00dac0dc6d18b93e124f36614686502e55cb
+DIST logwatch-7.11.tar.gz 513041 BLAKE2B 074b9b1d58bd199c82edc6fb40703b71f9488966e2acb8afc015fde93806740d11a3c8705303139716bbc50c353f3e8c3f4c0e9cf1d5f870cbb8599fbdd526d1 SHA512 1af075ad2459fade202396af5fa50b705b4635b71b5fc3be832df80c491baa1dd726b3023f84ecbb621e0e19004a0f8cdb017e657c4511bcd4cbd3205177ce22
DIST logwatch-7.9.tar.gz 501086 BLAKE2B ebfc65c88036244840fe4fbf42c0bea668cac3063771f0042827a2f583d654403b75bdfa428f50a7fdac5f0098ec08ef5a27006db7f7576b361653594462d607 SHA512 d091fbbeb0cac4b661fb066118fd384dbdeabe137c699ea6892d53567a45978c0742b1be9cf2f8b8c2e522314351ee6c2e3710ac2e61bbf1a3c8d63f78a3646f
diff --git a/sys-apps/logwatch/files/logwatch-7.11-openssh-9.8.patch b/sys-apps/logwatch/files/logwatch-7.11-openssh-9.8.patch
new file mode 100644
index 000000000000..1162115f3f09
--- /dev/null
+++ b/sys-apps/logwatch/files/logwatch-7.11-openssh-9.8.patch
@@ -0,0 +1,37 @@
+https://sourceforge.net/p/logwatch/patches/84/
+--- a/conf/services/secure.conf
++++ b/conf/services/secure.conf
+@@ -24,7 +24,7 @@ $secure_ip_lookup = No
+ # Use this to ignore certain services in the secure log.
+ # You can ignore as many services as you would like.
+ # (we ignore sshd because its entries are processed by the sshd script)
+-$ignore_services = sshd Pluto stunnel proftpd saslauthd imapd postfix/smtpd
++$ignore_services = sshd sshd-session Pluto stunnel proftpd saslauthd imapd postfix/smtpd
+
+ # For these services, summarize only (i.e. don't least each IP, just
+ # list the number of connections total)
+--- a/conf/services/sshd.conf
++++ b/conf/services/sshd.conf
+@@ -19,7 +19,7 @@ LogFile = secure
+ LogFile = messages
+
+ # Only give lines pertaining to the sshd service...
+-*OnlyService = sshd
++*OnlyService = (sshd|sshd-session)
+ *RemoveHeaders
+
+ # Variable $sshd_ignore_host is used to filter out hosts that login
+--- a/scripts/services/sshd
++++ b/scripts/services/sshd
+@@ -246,9 +246,9 @@ while (defined(my $ThisLine = <STDIN>)) {
+ $NoIdent{$name}++;
+ } elsif (
+ ($ThisLine =~ m/^(?:error:.*|fatal:) Connection closed by remote host/ ) or
+- ($ThisLine =~ m/^(|fatal: )Read error from remote host(| [^ ]+): Connection reset by peer/ ) or
++ ($ThisLine =~ m/^(|fatal: )Read error from remote host(| [^ ]+)(| port \d+): Connection reset by peer/ ) or
+ ($ThisLine =~ m/^error: .*: read: Connection reset by peer/ ) or
+- ($ThisLine =~ m/^Read error from remote host [^ ]+: (Connection timed out|No route to host)/ ) or
++ ($ThisLine =~ m/^Read error from remote host [^ ]+(| port \d+): (Connection timed out|No route to host)/ ) or
+ ($ThisLine =~ m/^fatal: Read from socket failed: No route to host/) or
+ ($ThisLine =~ m/^fatal: Write failed: Network is unreachable/ ) or
+ ($ThisLine =~ m/^fatal: Write failed: Broken pipe/) or
diff --git a/sys-apps/logwatch/logwatch-7.11.ebuild b/sys-apps/logwatch/logwatch-7.11.ebuild
new file mode 100644
index 000000000000..b495a9f557bd
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.11.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit tmpfiles
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="https://sourceforge.net/projects/logwatch/"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://downloads.sourceforge.net/${PN}/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="selinux"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/Date-Manip
+ dev-perl/HTML-Parser
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo
+ virtual/cron
+ virtual/mta
+ virtual/mailx
+ selinux? ( sec-policy/selinux-logwatch )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-openssh-9.8.patch
+)
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ # logwatch.pl requires cache dir (bug #607668)
+ newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else (bug #100243)
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+
+ # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
+ tmpfiles_process ${PN}.conf
+}