summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-03-19 13:45:38 -0500
committerWilliam Hubbs <williamh@gentoo.org>2018-03-19 13:46:07 -0500
commit4ecb6fb2b5a9012f44c6727509de2a3e77930fb7 (patch)
treea4738c1d699d370c6f32c8ea61237deaef71de3d /sys-apps/baselayout
parentdev-ruby/ox: add missing ruby22 (diff)
downloadgentoo-4ecb6fb2b5a9012f44c6727509de2a3e77930fb7.tar.gz
gentoo-4ecb6fb2b5a9012f44c6727509de2a3e77930fb7.tar.bz2
gentoo-4ecb6fb2b5a9012f44c6727509de2a3e77930fb7.zip
sys-apps/baselayout: live ebuild: add warning about path change
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/baselayout-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sys-apps/baselayout/baselayout-9999.ebuild b/sys-apps/baselayout/baselayout-9999.ebuild
index 20a7143a7421..6bd0c0d4f707 100644
--- a/sys-apps/baselayout/baselayout-9999.ebuild
+++ b/sys-apps/baselayout/baselayout-9999.ebuild
@@ -245,10 +245,14 @@ pkg_postinst() {
fi
for x in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 2.4 ${v}; then
+ if ! version_is_at_least 2.4 ${x}; then
ewarn "After updating ${EROOT}etc/profile, please run"
- ewarn "env-update and . /etc/profile"
- break
+ ewarn "env-update && . /etc/profile"
+ fi
+
+ if ! version_is_at_least 2.5 ${x}; then
+ ewarn "Please run env-update then log out and back in to"
+ ewarn "update your path."
fi
done