summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/jags
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/jags')
-rw-r--r--sci-mathematics/jags/Manifest1
-rw-r--r--sci-mathematics/jags/jags-3.4.0.ebuild47
-rw-r--r--sci-mathematics/jags/metadata.xml18
3 files changed, 66 insertions, 0 deletions
diff --git a/sci-mathematics/jags/Manifest b/sci-mathematics/jags/Manifest
new file mode 100644
index 000000000000..345adf71ae05
--- /dev/null
+++ b/sci-mathematics/jags/Manifest
@@ -0,0 +1 @@
+DIST JAGS-3.4.0.tar.gz 1677450 SHA256 2beaa9a2672c2c95efc55ffa4c8b597a872f20232373daebd17ad539d3d7d82b SHA512 7a330ea41eab63b23d8ae3622c6920f0dc3dba653a18256957b9b862bb86b746ff706e9e9bf3f806524250b439161a6df4ad05af682354073f9b0074f9825896 WHIRLPOOL 48f2bf92f80ea0558697701320e142a61b3eb5cfefe234973a6a189096b7887ec5ea829f8f6183bf9ad4a0f6fb07d769c710b721ec1e211772cbeaea0187c8e2
diff --git a/sci-mathematics/jags/jags-3.4.0.ebuild b/sci-mathematics/jags/jags-3.4.0.ebuild
new file mode 100644
index 000000000000..f004eb90acc3
--- /dev/null
+++ b/sci-mathematics/jags/jags-3.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils toolchain-funcs
+
+MYP="JAGS-${PV}"
+
+DESCRIPTION="Just Another Gibbs Sampler for Bayesian MCMC simulation"
+HOMEPAGE="http://mcmc-jags.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/mcmc-jags/JAGS/3.x/Source/${MYP}.tar.gz"
+LICENSE="GPL-2"
+IUSE="doc"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo docs)
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc "${BUILD_DIR}"/doc/manual/*.pdf
+}
diff --git a/sci-mathematics/jags/metadata.xml b/sci-mathematics/jags/metadata.xml
new file mode 100644
index 000000000000..9a890cc0f1cc
--- /dev/null
+++ b/sci-mathematics/jags/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
+ JAGS is Just Another Gibbs Sampler. It is a program for analysis of
+ Bayesian hierarchical models using Markov Chain Monte Carlo (MCMC)
+ simulation not wholly unlike BUGS.
+ JAGS was written with three aims in mind:
+ * To have an engine for the BUGS language that runs on Unix
+ * To be extensible, allowing users to write their own functions,
+ distributions and samplers.
+ * To be a plaftorm for experimentation with ideas in Bayesian modelling
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">mcmc-jags</remote-id>
+ </upstream>
+</pkgmetadata>