summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-22 02:13:30 +0000
committerSam James <sam@gentoo.org>2022-03-22 02:13:43 +0000
commit3af4933852ab0021e667db087ca55911f1f75382 (patch)
tree2fb2f35d6eaac2801abae6cc9a234095219dcf9a /sci-libs/libgeotiff
parentapp-admin/keepassxc: Bump to version 2.7.0. Removed old (diff)
downloadgentoo-3af4933852ab0021e667db087ca55911f1f75382.tar.gz
gentoo-3af4933852ab0021e667db087ca55911f1f75382.tar.bz2
gentoo-3af4933852ab0021e667db087ca55911f1f75382.zip
sci-libs/libgeotiff: update CMake patch
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/libgeotiff')
-rw-r--r--sci-libs/libgeotiff/files/libgeotiff-1.7.1-gnuinstalldirs.patch24
-rw-r--r--sci-libs/libgeotiff/libgeotiff-1.7.1-r1.ebuild (renamed from sci-libs/libgeotiff/libgeotiff-1.7.1.ebuild)0
2 files changed, 23 insertions, 1 deletions
diff --git a/sci-libs/libgeotiff/files/libgeotiff-1.7.1-gnuinstalldirs.patch b/sci-libs/libgeotiff/files/libgeotiff-1.7.1-gnuinstalldirs.patch
index 47ee7050aa8a..6fdcd9753f95 100644
--- a/sci-libs/libgeotiff/files/libgeotiff-1.7.1-gnuinstalldirs.patch
+++ b/sci-libs/libgeotiff/files/libgeotiff-1.7.1-gnuinstalldirs.patch
@@ -1,6 +1,6 @@
https://github.com/OSGeo/libgeotiff/pull/74
-From 8541a109f3aad4756488f730ed8d71060f9b282f Mon Sep 17 00:00:00 2001
+From d18deccb461990c826ceee8fbcc57a44502ace2e Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
Date: Sun, 20 Mar 2022 02:55:50 +0000
Subject: [PATCH] CMake: adopt GNUInstallDirs
@@ -13,7 +13,15 @@ This works cross-platform still but it means libgeotiff uses the
standard options which CMake projects tend to use for such locations
and therefore no special treatment is needed when packaging it.
+Fixes: https://github.com/OSGeo/issues/33
Signed-off-by: Sam James <sam@gentoo.org>
+---
+ CMakeLists.txt | 41 ++++++++++-------------------------
+ bin/CMakeLists.txt | 6 ++---
+ 2 files changed, 14 insertions(+), 33 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 001df67..1840258 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,8 @@
@@ -96,3 +104,17 @@ Signed-off-by: Sam James <sam@gentoo.org>
# Define grouping of source files in PROJECT file (e.g. Visual Studio)
SOURCE_GROUP("CMake Files" FILES CMakeLists.txt)
+diff --git a/bin/CMakeLists.txt b/bin/CMakeLists.txt
+index dad465f..c61585c 100644
+--- a/bin/CMakeLists.txt
++++ b/bin/CMakeLists.txt
+@@ -41,6 +41,6 @@ MESSAGE(STATUS "Adding GeoTIFF utilities to build - done: ${GEOTIFF_UTILITIES}")
+ # Targets installation
+
+ INSTALL(TARGETS ${GEOTIFF_UTILITIES}
+- RUNTIME DESTINATION ${GEOTIFF_BIN_DIR}
+- LIBRARY DESTINATION ${GEOTIFF_LIB_DIR}
+- ARCHIVE DESTINATION ${GEOTIFF_LIB_DIR})
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
diff --git a/sci-libs/libgeotiff/libgeotiff-1.7.1.ebuild b/sci-libs/libgeotiff/libgeotiff-1.7.1-r1.ebuild
index fe5e5d7051fc..fe5e5d7051fc 100644
--- a/sci-libs/libgeotiff/libgeotiff-1.7.1.ebuild
+++ b/sci-libs/libgeotiff/libgeotiff-1.7.1-r1.ebuild