summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-11-12 08:48:04 -0500
committerMichael Orlitzky <mjo@gentoo.org>2023-11-12 09:14:14 -0500
commit3224edf96bf428368b5f26d015f01064a3cb7ac8 (patch)
treedcb88886d787e44deffeacd68c17589b7143b60b /sci-libs/fplll
parentapp-office/texmaker: drop 5.0.4 (diff)
downloadgentoo-3224edf96bf428368b5f26d015f01064a3cb7ac8.tar.gz
gentoo-3224edf96bf428368b5f26d015f01064a3cb7ac8.tar.bz2
gentoo-3224edf96bf428368b5f26d015f01064a3cb7ac8.zip
sci-libs/fplll: add 5.4.5
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/fplll')
-rw-r--r--sci-libs/fplll/Manifest1
-rw-r--r--sci-libs/fplll/fplll-5.4.5.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/fplll/Manifest b/sci-libs/fplll/Manifest
index 6cb16cd50382..7e0d81296e8f 100644
--- a/sci-libs/fplll/Manifest
+++ b/sci-libs/fplll/Manifest
@@ -1 +1,2 @@
DIST fplll-5.4.4.tar.gz 2630101 BLAKE2B b990c9346acd2c506b4697f27ff21d8453bb97473b2e988beb2ab9da34b3edd8a64d7558bca5f66a888fb4397c1e5340cf50f543ec580f0ec6980bc8c73a9390 SHA512 32a6515a3ab2677739a60a4ef0938e4284b5d3119a396104a7af22a6291ef669b42a4fb6e59f5c6daf97ff2402e7d035ea84fd1c76bfe7c0e17402bd03ae7166
+DIST fplll-5.4.5.tar.gz 2630275 BLAKE2B 43d1601f401c3a4eba60939028b26f99d32f92b9d53b763768427d05b2d709645532c4fbb14556c8d8d92cc14efe86468469ed69a77bdb03af75ec08499cc17e SHA512 3e1281f1b993ebe4a767b7fc526f49a27d58f24b1b4c6074310cc971f6f569388d6ba27102087a2eb11671d2d5b87bd60306e2597567f4ae8dd2a9efd13beb77
diff --git a/sci-libs/fplll/fplll-5.4.5.ebuild b/sci-libs/fplll/fplll-5.4.5.ebuild
new file mode 100644
index 000000000000..d8ad2144d60b
--- /dev/null
+++ b/sci-libs/fplll/fplll-5.4.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="https://github.com/fplll/fplll"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8"
+KEYWORDS="~amd64 ~x86"
+IUSE="qd"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/gmp:0
+ dev-libs/mpfr:0
+ qd? ( sci-libs/qd )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with qd)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}