summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-15 15:51:11 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-15 15:51:19 +0100
commit16bf008276ac8211bfbe1b6ab9151e1d5893d6e9 (patch)
tree2fedabccd915be30b3f7740966c6b520ce9a148b /sci-libs/ViSP/files
parentsci-libs/ViSP: fix build with ffmpeg3. (diff)
downloadgentoo-16bf008276ac8211bfbe1b6ab9151e1d5893d6e9.tar.gz
gentoo-16bf008276ac8211bfbe1b6ab9151e1d5893d6e9.tar.bz2
gentoo-16bf008276ac8211bfbe1b6ab9151e1d5893d6e9.zip
sci-libs/ViSP: remove old
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-libs/ViSP/files')
-rw-r--r--sci-libs/ViSP/files/ffmpeg.patch78
-rw-r--r--sci-libs/ViSP/files/opencv.patch13
-rw-r--r--sci-libs/ViSP/files/opencv3.patch67
3 files changed, 0 insertions, 158 deletions
diff --git a/sci-libs/ViSP/files/ffmpeg.patch b/sci-libs/ViSP/files/ffmpeg.patch
deleted file mode 100644
index 5c81d0505095..000000000000
--- a/sci-libs/ViSP/files/ffmpeg.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-Index: ViSP-2.10.0/src/video/vpFFMPEG.cpp
-===================================================================
---- ViSP-2.10.0.orig/src/video/vpFFMPEG.cpp
-+++ ViSP-2.10.0/src/video/vpFFMPEG.cpp
-@@ -184,7 +184,7 @@ bool vpFFMPEG::openStream(const char *fi
- if (pFrameRGB == NULL)
- return false;
-
-- numBytes = avpicture_get_size (PIX_FMT_RGB24,pCodecCtx->width,pCodecCtx->height);
-+ numBytes = avpicture_get_size (AV_PIX_FMT_RGB24,pCodecCtx->width,pCodecCtx->height);
- }
-
- else if (color_type == vpFFMPEG::GRAY_SCALED)
-@@ -198,7 +198,7 @@ bool vpFFMPEG::openStream(const char *fi
- if (pFrameGRAY == NULL)
- return false;
-
-- numBytes = avpicture_get_size (PIX_FMT_GRAY8,pCodecCtx->width,pCodecCtx->height);
-+ numBytes = avpicture_get_size (AV_PIX_FMT_GRAY8,pCodecCtx->width,pCodecCtx->height);
- }
-
- /*
-@@ -215,10 +215,10 @@ bool vpFFMPEG::openStream(const char *fi
- }
-
- if (color_type == vpFFMPEG::COLORED)
-- avpicture_fill((AVPicture *)pFrameRGB, buffer, PIX_FMT_RGB24, pCodecCtx->width, pCodecCtx->height);
-+ avpicture_fill((AVPicture *)pFrameRGB, buffer, AV_PIX_FMT_RGB24, pCodecCtx->width, pCodecCtx->height);
-
- else if (color_type == vpFFMPEG::GRAY_SCALED)
-- avpicture_fill((AVPicture *)pFrameGRAY, buffer, PIX_FMT_GRAY8, pCodecCtx->width, pCodecCtx->height);
-+ avpicture_fill((AVPicture *)pFrameGRAY, buffer, AV_PIX_FMT_GRAY8, pCodecCtx->width, pCodecCtx->height);
-
- streamWasOpen = true;
-
-@@ -235,10 +235,10 @@ bool vpFFMPEG::openStream(const char *fi
- bool vpFFMPEG::initStream()
- {
- if (color_type == vpFFMPEG::COLORED)
-- img_convert_ctx= sws_getContext(pCodecCtx->width, pCodecCtx->height, pCodecCtx->pix_fmt, pCodecCtx->width,pCodecCtx->height,PIX_FMT_RGB24, SWS_BICUBIC, NULL, NULL, NULL);
-+ img_convert_ctx= sws_getContext(pCodecCtx->width, pCodecCtx->height, pCodecCtx->pix_fmt, pCodecCtx->width,pCodecCtx->height,AV_PIX_FMT_RGB24, SWS_BICUBIC, NULL, NULL, NULL);
-
- else if (color_type == vpFFMPEG::GRAY_SCALED)
-- img_convert_ctx= sws_getContext(pCodecCtx->width, pCodecCtx->height, pCodecCtx->pix_fmt, pCodecCtx->width,pCodecCtx->height,PIX_FMT_GRAY8, SWS_BICUBIC, NULL, NULL, NULL);
-+ img_convert_ctx= sws_getContext(pCodecCtx->width, pCodecCtx->height, pCodecCtx->pix_fmt, pCodecCtx->width,pCodecCtx->height,AV_PIX_FMT_GRAY8, SWS_BICUBIC, NULL, NULL, NULL);
-
- int ret = av_seek_frame(pFormatCtx, (int)videoStream, 0, AVSEEK_FLAG_ANY) ;
- if (ret < 0 )
-@@ -707,7 +707,7 @@ bool vpFFMPEG::openEncoder(const char *f
- pCodecCtx->time_base.den = framerate_encoder;
- pCodecCtx->gop_size = 10; /* emit one intra frame every ten frames */
- pCodecCtx->max_b_frames=1;
-- pCodecCtx->pix_fmt = PIX_FMT_YUV420P;
-+ pCodecCtx->pix_fmt = AV_PIX_FMT_YUV420P;
-
- /* open it */
- #if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(53,35,0) // libavcodec 53.35.0
-@@ -730,15 +730,15 @@ bool vpFFMPEG::openEncoder(const char *f
- outbuf_size = 100000;
- outbuf = new uint8_t[outbuf_size];
-
-- numBytes = avpicture_get_size (PIX_FMT_YUV420P,pCodecCtx->width,pCodecCtx->height);
-+ numBytes = avpicture_get_size (AV_PIX_FMT_YUV420P,pCodecCtx->width,pCodecCtx->height);
- picture_buf = new uint8_t[numBytes];
-- avpicture_fill((AVPicture *)pFrame, picture_buf, PIX_FMT_YUV420P, pCodecCtx->width, pCodecCtx->height);
-+ avpicture_fill((AVPicture *)pFrame, picture_buf, AV_PIX_FMT_YUV420P, pCodecCtx->width, pCodecCtx->height);
-
-- numBytes = avpicture_get_size (PIX_FMT_RGB24,pCodecCtx->width,pCodecCtx->height);
-+ numBytes = avpicture_get_size (AV_PIX_FMT_RGB24,pCodecCtx->width,pCodecCtx->height);
- buffer = new uint8_t[numBytes];
-- avpicture_fill((AVPicture *)pFrameRGB, buffer, PIX_FMT_RGB24, pCodecCtx->width, pCodecCtx->height);
-+ avpicture_fill((AVPicture *)pFrameRGB, buffer, AV_PIX_FMT_RGB24, pCodecCtx->width, pCodecCtx->height);
-
-- img_convert_ctx= sws_getContext(pCodecCtx->width, pCodecCtx->height, PIX_FMT_RGB24, pCodecCtx->width,pCodecCtx->height,PIX_FMT_YUV420P, SWS_BICUBIC, NULL, NULL, NULL);
-+ img_convert_ctx= sws_getContext(pCodecCtx->width, pCodecCtx->height, AV_PIX_FMT_RGB24, pCodecCtx->width,pCodecCtx->height,AV_PIX_FMT_YUV420P, SWS_BICUBIC, NULL, NULL, NULL);
-
- encoderWasOpened = true;
-
diff --git a/sci-libs/ViSP/files/opencv.patch b/sci-libs/ViSP/files/opencv.patch
deleted file mode 100644
index c8cafe0a5c97..000000000000
--- a/sci-libs/ViSP/files/opencv.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: ViSP-2.10.0/CMakeLists.txt
-===================================================================
---- ViSP-2.10.0.orig/CMakeLists.txt
-+++ ViSP-2.10.0/CMakeLists.txt
-@@ -1450,7 +1450,7 @@ if(USE_OPENCV)
- list(APPEND VISP_EXTERN_LIBRARIES ${OpenCV_LIBS})
- endif()
- list(APPEND VISP_EXTERN_INCLUDE_DIRS ${OpenCV_INCLUDE_DIRS})
-- #LIST(APPEND VISP_EXTERN_LIBRARIES ${OpenCV_LIBS})
-+ LIST(APPEND VISP_EXTERN_LIBRARIES ${OpenCV_LIBRARIES})
- #MESSAGE("OpenCV_INCLUDE_DIRS = ${OpenCV_INCLUDE_DIRS}")
- #MESSAGE("OpenCV_LIBS = ${OpenCV_LIBS}")
- #MESSAGE("OpenCV_LIB_DIR = ${OpenCV_LIB_DIR}")
diff --git a/sci-libs/ViSP/files/opencv3.patch b/sci-libs/ViSP/files/opencv3.patch
deleted file mode 100644
index 8f7f9ee269cd..000000000000
--- a/sci-libs/ViSP/files/opencv3.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-Index: ViSP-2.10.0/src/key-point/vpKeyPoint.h
-===================================================================
---- ViSP-2.10.0.orig/src/key-point/vpKeyPoint.h
-+++ ViSP-2.10.0/src/key-point/vpKeyPoint.h
-@@ -494,6 +494,7 @@ public:
- initDetector(detectorName);
- }
-
-+#if (VISP_HAVE_OPENCV_VERSION >= 0x020400 && VISP_HAVE_OPENCV_VERSION < 0x030000)
- /*!
- Template function to set to a \p parameterName a value for a specific detector named by his \p detectorName.
-
-@@ -507,6 +508,7 @@ public:
- m_detectors[detectorName]->set(parameterName, value);
- }
- }
-+#endif
-
- /*!
- Set and initialize a list of detectors denominated by their names \p detectorNames.
-@@ -532,6 +534,7 @@ public:
- initExtractor(extractorName);
- }
-
-+#if (VISP_HAVE_OPENCV_VERSION >= 0x020400 && VISP_HAVE_OPENCV_VERSION < 0x030000)
- /*!
- Template function to set to a \p parameterName a value for a specific extractor named by his \p extractorName.
-
-@@ -545,6 +548,7 @@ public:
- m_extractors[extractorName]->set(parameterName, value);
- }
- }
-+#endif
-
- /*!
- Set and initialize a list of extractors denominated by their names \p extractorNames.
-@@ -700,7 +704,7 @@ public:
- m_useAffineDetection = useAffine;
- }
-
--#if (VISP_HAVE_OPENCV_VERSION >= 0x020400)
-+#if (VISP_HAVE_OPENCV_VERSION >= 0x020400 && VISP_HAVE_OPENCV_VERSION < 0x030000)
- /*!
- Set if cross check method must be used to eliminate some false matches with a brute-force matching method.
-
-Index: ViSP-2.10.0/src/key-point/vpKeyPoint.cpp
-===================================================================
---- ViSP-2.10.0.orig/src/key-point/vpKeyPoint.cpp
-+++ ViSP-2.10.0/src/key-point/vpKeyPoint.cpp
-@@ -868,7 +868,7 @@ void vpKeyPoint::detect(const vpImage<un
- (int) rectangle.getBottom());
- cv::rectangle(mask, leftTop, rightBottom, cv::Scalar(255), CV_FILLED);
- } else {
-- mask = cv::Mat::ones(matImg.rows, matImg.cols, CV_8U);
-+ mask = cv::Mat::ones(matImg.rows, matImg.cols, CV_8U) * 255;
- }
-
- detect(matImg, keyPoints, elapsedTime, mask);
-@@ -1544,7 +1544,7 @@ void vpKeyPoint::initExtractors(const st
- void vpKeyPoint::initMatcher(const std::string &matcherName) {
- m_matcher = cv::DescriptorMatcher::create(matcherName);
-
--#if (VISP_HAVE_OPENCV_VERSION >= 0x020400)
-+#if (VISP_HAVE_OPENCV_VERSION >= 0x020400 && VISP_HAVE_OPENCV_VERSION < 0x030000)
- if(m_matcher != NULL && !m_useKnn && matcherName == "BruteForce") {
- m_matcher->set("crossCheck", m_useBruteForceCrossCheck);
- }