summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-08-02 14:34:57 -0400
committerZero_Chaos <zerochaos@gentoo.org>2018-08-02 14:35:22 -0400
commitd9ba9843cdb7df8d267580bb4a02635dc74d01bd (patch)
tree75934f922a4246aca719d9b6bb5aeffb02ac6af2 /net-wireless/kismet
parentmedia-video/mjpegtools: Remove old. (diff)
downloadgentoo-d9ba9843cdb7df8d267580bb4a02635dc74d01bd.tar.gz
gentoo-d9ba9843cdb7df8d267580bb4a02635dc74d01bd.tar.bz2
gentoo-d9ba9843cdb7df8d267580bb4a02635dc74d01bd.zip
net-wireless/kismet: beta wooooooo
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'net-wireless/kismet')
-rw-r--r--net-wireless/kismet/Manifest1
-rw-r--r--net-wireless/kismet/kismet-2018.08_beta1.ebuild116
-rw-r--r--net-wireless/kismet/kismet-9999.ebuild91
3 files changed, 129 insertions, 79 deletions
diff --git a/net-wireless/kismet/Manifest b/net-wireless/kismet/Manifest
index ed814f560093..fc94567a992e 100644
--- a/net-wireless/kismet/Manifest
+++ b/net-wireless/kismet/Manifest
@@ -1 +1,2 @@
DIST kismet-2016-07-R1.tar.xz 709364 BLAKE2B 5b667a02b517bd413d569f40df1f2a2e1158357c602fa807d712870543a7fade25077f449c07c023ad1d2150870352aa754484846d8c2a0d9f027113bb57c1fc SHA512 88891a0cd5ef94a4815d259e433f946f52552c125e05a5d8ac447d04e6090f2bd92f8bd8573440f0dfe446b29233bef81d9889e53170757ad0116ddfc2cb8416
+DIST kismet-2018-08-BETA1.tar.xz 2043136 BLAKE2B f24af4250bb0238073380514413d9501e449cf40507d7a96ac868d76acb34af81b9bf4a49c9b6197b6b903ab33e2318bb5efa22876cc2070e3878ebf030d592c SHA512 09eab9d648f011c95b8632c666990d79f9998465b051a65357f53af19a135a5d58df3025ec60f9ef9a7b7d9b5622d2332bb2defbffd21ca0e25e2e4090ceae2f
diff --git a/net-wireless/kismet/kismet-2018.08_beta1.ebuild b/net-wireless/kismet/kismet-2018.08_beta1.ebuild
new file mode 100644
index 000000000000..1f6e8da8176c
--- /dev/null
+++ b/net-wireless/kismet/kismet-2018.08_beta1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils multilib user python-single-r1
+
+MY_P=${P/\./-}
+MY_P=${MY_P/_beta/-BETA}
+MY_P=${MY_P/./-R}
+S=${WORKDIR}/${MY_P}
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://www.kismetwireless.net/${PN}.git"
+ SRC_URI=""
+ inherit git-r3
+ KEYWORDS=""
+ RESTRICT="strip"
+else
+ SRC_URI="https://www.kismetwireless.net/code/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+fi
+
+DESCRIPTION="IEEE 802.11 wireless LAN sniffer"
+HOMEPAGE="https://www.kismetwireless.net"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="lm_sensors +pcre selinux +suid"
+
+CDEPEND="
+ ${PYTHON_DEPS}
+ net-misc/networkmanager:=
+ dev-libs/glib:=
+ dev-libs/elfutils:=
+ sys-libs/zlib:=
+ dev-db/sqlite:=
+ net-libs/libmicrohttpd
+ kernel_linux? ( sys-libs/libcap
+ dev-libs/libnl:3
+ net-libs/libpcap
+ )
+ dev-libs/protobuf-c:=
+ sys-libs/ncurses:=
+ lm_sensors? ( sys-apps/lm_sensors )
+ pcre? ( dev-libs/libpcre )
+ suid? ( sys-libs/libcap )
+ "
+
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-kismet )
+"
+
+src_prepare() {
+ sed -i -e "s:^\(logtemplate\)=\(.*\):\1=/tmp/\2:" \
+ conf/kismet_logging.conf || die
+
+ # Don't strip and set correct mangrp
+ sed -i -e 's| -s||g' \
+ -e 's|@mangrp@|root|g' Makefile.in
+
+ epatch "${FILESDIR}"/fix-setuptools.patch
+ eapply_user
+ if [[ ${PV} == "9999" ]] ; then
+ sed -i 's#-O3##' configure.ac
+ eautoreconf
+ else
+ sed -i 's#-O3##' configure
+ fi
+}
+
+src_configure() {
+ if ! use lm_sensors; then
+ adddeny /usr/include/sensors/sensors.h
+ fi
+ econf \
+ $(use_enable pcre)
+}
+
+src_install() {
+ emake DESTDIR="${D}" commoninstall
+ emake DESTDIR="${D}" forceconfigs
+
+ #dodoc CHANGELOG RELEASENOTES.txt README* docs/DEVEL.client docs/README.newcore
+ dodoc CHANGELOG README*
+ newinitd "${FILESDIR}"/${PN}.initd kismet
+ newconfd "${FILESDIR}"/${PN}.confd kismet
+}
+
+pkg_preinst() {
+ if use suid; then
+ enewgroup kismet
+ fowners root:kismet /usr/bin/kismet_cap_linux_bluetooth
+ fowners root:kismet /usr/bin/kismet_cap_linux_wifi
+ fowners root:kismet /usr/bin/kismet_cap_pcapfile
+ # Need to set the permissions after chowning.
+ # See chown(2)
+ fperms 4550 /usr/bin/kismet_cap_linux_bluetooth
+ fperms 4550 /usr/bin/kismet_cap_linux_wifi
+ fperms 4550 /usr/bin/kismet_cap_pcapfile
+ elog "Kismet has been installed with a setuid-root helper binary"
+ elog "to enable minimal-root operation. Users need to be part of"
+ elog "the 'kismet' group to perform captures from physical devices."
+ fi
+ if ! use suid; then
+ ewarn "It is highly discouraged to run a sniffer as root,"
+ ewarn "Please consider enabling the suid use flag and adding"
+ ewarn "your user to the kismet group."
+ fi
+}
diff --git a/net-wireless/kismet/kismet-9999.ebuild b/net-wireless/kismet/kismet-9999.ebuild
index 2a6321ed5126..1f6e8da8176c 100644
--- a/net-wireless/kismet/kismet-9999.ebuild
+++ b/net-wireless/kismet/kismet-9999.ebuild
@@ -8,6 +8,7 @@ PYTHON_COMPAT=( python2_7 )
inherit autotools eutils multilib user python-single-r1
MY_P=${P/\./-}
+MY_P=${MY_P/_beta/-BETA}
MY_P=${MY_P/./-R}
S=${WORKDIR}/${MY_P}
@@ -27,7 +28,7 @@ HOMEPAGE="https://www.kismetwireless.net"
LICENSE="GPL-2"
SLOT="0/${PV}"
-IUSE="+pcre speech selinux +suid"
+IUSE="lm_sensors +pcre selinux +suid"
CDEPEND="
${PYTHON_DEPS}
@@ -43,13 +44,10 @@ CDEPEND="
)
dev-libs/protobuf-c:=
sys-libs/ncurses:=
+ lm_sensors? ( sys-apps/lm_sensors )
pcre? ( dev-libs/libpcre )
suid? ( sys-libs/libcap )
- !arm? ( speech? ( app-accessibility/flite ) )
"
- #plugin-btscan? ( net-wireless/bluez )
- #plugin-dot15d4? ( virtual/libusb:0 )
- #plugin-spectools? ( net-wireless/spectools )
DEPEND="${CDEPEND}
virtual/pkgconfig
@@ -69,95 +67,30 @@ src_prepare() {
epatch "${FILESDIR}"/fix-setuptools.patch
eapply_user
- eautoreconf
+ if [[ ${PV} == "9999" ]] ; then
+ sed -i 's#-O3##' configure.ac
+ eautoreconf
+ else
+ sed -i 's#-O3##' configure
+ fi
}
src_configure() {
+ if ! use lm_sensors; then
+ adddeny /usr/include/sensors/sensors.h
+ fi
econf \
$(use_enable pcre)
- #--disable-python-tools
-}
-
-src_compile() {
- emake
-
- #if use plugin-autowep; then
- # cd "${S}"/restricted-plugin-autowep
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-btscan; then
- # cd "${S}"/plugin-btscan
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-dot15d4; then
- # cd "${S}"/plugin-dot15d4
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-ptw; then
- # cd "${S}"/restricted-plugin-ptw
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-spectools; then
- # cd "${S}"/plugin-spectools
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-syslog; then
- # cd "${S}"/plugin-syslog
- # KIS_SRC_DIR="${S}" emake
- #fi
}
src_install() {
- #if use plugin-autowep; then
- # cd "${S}"/restricted-plugin-autowep
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-btscan; then
- # cd "${S}"/plugin-btscan
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-dot15d4; then
- # cd "${S}"/plugin-dot15d4
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-ptw; then
- # cd "${S}"/restricted-plugin-ptw
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-spectools; then
- # cd "${S}"/plugin-spectools
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-syslog; then
- # cd "${S}"/plugin-syslog
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use ruby; then
- # cd "${S}"/ruby
- # dobin *.rb
- #fi
-
- #cd "${S}"
emake DESTDIR="${D}" commoninstall
emake DESTDIR="${D}" forceconfigs
- ##dragorn would prefer I set fire to my head than do this, but it works
- ##all external kismet plugins (read: kismet-ubertooth) must be rebuilt when kismet is
- ##is there an automatic way to force this?
- # install headers for external plugins
- insinto /usr/include/kismet
- doins *.h
- doins Makefile.inc
- #todo write a plugin finder that tells you what needs to be rebuilt when kismet is updated, etc
-
#dodoc CHANGELOG RELEASENOTES.txt README* docs/DEVEL.client docs/README.newcore
dodoc CHANGELOG README*
newinitd "${FILESDIR}"/${PN}.initd kismet
newconfd "${FILESDIR}"/${PN}.confd kismet
-
- #if use suid; then
- # dobin kismet_capture
- #fi
}
pkg_preinst() {