summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-04-08 22:21:42 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-04-10 20:34:52 +0200
commita1e411930598901f2470f8c4ec095596a2496ee2 (patch)
treedd9d6a7b1017b373d2017acf1c0837e0572e2a30 /net-misc/gofish/gofish-1.2-r1.ebuild
parentnet-misc/gofish: Tidy up ebuild (diff)
downloadgentoo-a1e411930598901f2470f8c4ec095596a2496ee2.tar.gz
gentoo-a1e411930598901f2470f8c4ec095596a2496ee2.tar.bz2
gentoo-a1e411930598901f2470f8c4ec095596a2496ee2.zip
net-misc/gofish: Migrate from user.eclass
* Bump to EAPI 7 * Migrate from enewuser to GLEP 81 user/group Closes: https://bugs.gentoo.org/781413 Closes: https://github.com/gentoo/gentoo/pull/20309 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc/gofish/gofish-1.2-r1.ebuild')
-rw-r--r--net-misc/gofish/gofish-1.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/gofish/gofish-1.2-r1.ebuild b/net-misc/gofish/gofish-1.2-r1.ebuild
new file mode 100644
index 000000000000..fa82bccbe174
--- /dev/null
+++ b/net-misc/gofish/gofish-1.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Gofish gopher server"
+HOMEPAGE="http://gofish.sourceforge.net"
+SRC_URI="mirror://sourceforge/gofish/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ acct-group/gopher
+ acct-user/gopher
+"
+
+DOCS=( Configure_GoFish )
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --disable-mmap-cache
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/gofish-1.2-r1.rc gofish
+ newconfd "${FILESDIR}"/gofish-1.2-r1.confd gofish
+}