summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-15 11:19:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-22 19:52:43 +0100
commitead8f0a5c3d3434aa9bdf3068734aeaf585b5ba7 (patch)
tree9528b34ab411e1a8097bad53b3174d71d67d1081 /net-libs/srt
parentnet-libs/libssh2: update EAPI 7 -> 8 (diff)
downloadgentoo-ead8f0a5c3d3434aa9bdf3068734aeaf585b5ba7.tar.gz
gentoo-ead8f0a5c3d3434aa9bdf3068734aeaf585b5ba7.tar.bz2
gentoo-ead8f0a5c3d3434aa9bdf3068734aeaf585b5ba7.zip
net-libs/srt: drop unmaintained 9999 ebuild
Not synced with latest release, broken patch. Bug: https://bugs.gentoo.org/788256 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/srt')
-rw-r--r--net-libs/srt/srt-9999.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/net-libs/srt/srt-9999.ebuild b/net-libs/srt/srt-9999.ebuild
deleted file mode 100644
index 60f4c45f9b0a..000000000000
--- a/net-libs/srt/srt-9999.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2018-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-multilib
-
-DESCRIPTION="Secure Reliable Transport (SRT) library and tools"
-HOMEPAGE="https://github.com/Haivision/srt"
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/Haivision/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/Haivision/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 -sparc ~x86 ~ppc-macos ~x64-macos"
-fi
-
-LICENSE="MPL-2.0"
-SLOT="0"
-IUSE="gnutls test"
-
-RDEPEND="
- gnutls? (
- dev-libs/nettle:0=[${MULTILIB_USEDEP}]
- net-libs/gnutls:0=[${MULTILIB_USEDEP}]
- )
- !gnutls? (
- dev-libs/openssl:0=[${MULTILIB_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}
- test? ( dev-cpp/gtest )
-"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-always-GNUInstallDirs.patch"
-)
-
-src_prepare() {
- cmake_src_prepare
- sed -i -e "s:hcrypt_ut.c::" haicrypt/*.maf || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_STATIC=OFF
- -DUSE_GNUTLS=$(usex gnutls)
- -DENABLE_UNITTESTS=$(usex test)
- )
- cmake-multilib_src_configure
-}