summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-06-05 16:26:23 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-06-05 16:27:47 +0200
commit3700ca88ef7e0ee629f7749b3b8424a482d9bc34 (patch)
treede80ed05ced7d12f2a6a03e5cb70eddc8df1ea8f /net-libs/liboping
parentpackage.mask: Last rite dev-python/mysql-connector-python (diff)
downloadgentoo-3700ca88ef7e0ee629f7749b3b8424a482d9bc34.tar.gz
gentoo-3700ca88ef7e0ee629f7749b3b8424a482d9bc34.tar.bz2
gentoo-3700ca88ef7e0ee629f7749b3b8424a482d9bc34.zip
net-libs/liboping: EAPI 6 -> 8
Also fixed *.la files install. Closes: https://bugs.gentoo.org/848927 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-libs/liboping')
-rw-r--r--net-libs/liboping/liboping-1.10.0-r3.ebuild (renamed from net-libs/liboping/liboping-1.10.0-r2.ebuild)41
1 files changed, 23 insertions, 18 deletions
diff --git a/net-libs/liboping/liboping-1.10.0-r2.ebuild b/net-libs/liboping/liboping-1.10.0-r3.ebuild
index dfa32d0b9ef4..fc4d9550ae34 100644
--- a/net-libs/liboping/liboping-1.10.0-r2.ebuild
+++ b/net-libs/liboping/liboping-1.10.0-r3.ebuild
@@ -1,63 +1,68 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit autotools fcaps perl-module
DESCRIPTION="Protocol independent ANSI-C ping library and command line utility"
-HOMEPAGE="https://noping.cc/"
+HOMEPAGE="
+ https://noping.cc/
+ https://github.com/octo/liboping
+"
SRC_URI="https://noping.cc/files/${P}.tar.bz2"
-LICENSE="LGPL-2.1 GPL-2"
+LICENSE="GPL-2 LGPL-2.1"
SLOT="0/0.3"
KEYWORDS="~alpha amd64 arm x86"
IUSE="+filecaps ncurses perl"
DEPEND="ncurses? ( sys-libs/ncurses:0= )"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${PN}-1.10.0-no-werror.patch
+ "${FILESDIR}/${PN}-1.10.0-no-werror.patch"
"${FILESDIR}/${PN}-1.6.2-nouidmagic.patch"
- "${FILESDIR}"/${P}-gcc8-fix.patch
- "${FILESDIR}"/${P}-do-not-quit-when-ping_send-fail.patch
- "${FILESDIR}"/${P}-report-right-error-msg-when-select-fails.patch
+ "${FILESDIR}/${PN}-1.10.0-gcc8-fix.patch"
+ "${FILESDIR}/${PN}-1.10.0-do-not-quit-when-ping_send-fail.patch"
+ "${FILESDIR}/${PN}-1.10.0-report-right-error-msg-when-select-fails.patch"
)
src_prepare() {
default
-
eautoreconf
}
src_configure() {
- econf \
- $(use_with perl perl-bindings INSTALLDIRS=vendor) \
+ myeconfargs=(
$(use_with ncurses)
+ $(use_with perl perl-bindings INSTALLDIRS=vendor)
+ )
+
+ econf "${myeconfargs[@]}"
}
src_test() {
if use perl; then
- pushd bindings/perl >/dev/null || die
+ pushd bindings/perl || die
perl-module_src_test
- popd >/dev/null || die
+ popd || die
fi
}
src_install() {
default
-
- find "${ED}"usr/lib* -name '*.la' -o -name '*.a' -delete || die
+ find "${ED}" -type f -name '*.la' -delete || die
}
pkg_postinst() {
if use filecaps; then
local _caps_str="CAP_NET_RAW"
- _files=( "${EROOT%/}/usr/bin/oping")
+ _files=( "${EROOT}/usr/bin/oping")
if use ncurses; then
- _files+=( "${EROOT%/}/usr/bin/noping")
+ _files+=( "${EROOT}/usr/bin/noping")
fi
fcaps "${_caps_str}" "${_files[@]}"