summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/daq
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/daq')
-rw-r--r--net-libs/daq/Manifest3
-rw-r--r--net-libs/daq/daq-0.6.2-r1.ebuild69
-rw-r--r--net-libs/daq/daq-0.6.2.ebuild70
-rw-r--r--net-libs/daq/daq-2.0.0.ebuild69
-rw-r--r--net-libs/daq/daq-2.0.2.ebuild78
-rw-r--r--net-libs/daq/files/daq-2.0.2-libpcap-check.patch36
-rw-r--r--net-libs/daq/files/daq-2.0.2-parallel-grammar.patch39
-rw-r--r--net-libs/daq/metadata.xml36
8 files changed, 400 insertions, 0 deletions
diff --git a/net-libs/daq/Manifest b/net-libs/daq/Manifest
new file mode 100644
index 000000000000..03e713150297
--- /dev/null
+++ b/net-libs/daq/Manifest
@@ -0,0 +1,3 @@
+DIST daq-0.6.2.tar.gz 451581 SHA256 0159865b5dc127ed2faf8d6732d781939f27e38b7c7deabcd369a22ea9e42f26 SHA512 da19034f210d9c202f5e3ba7ddf60645498ed8bdaf28410811922ebb1338b56c55c8e992e46e1c7b9b89de6148b471129826a02ab2a45c7232bc4091a4e53125 WHIRLPOOL 01e7b47e27b71d11648936911bb9bd2657b387fd15eb41f5939b23b3e2da9753d66165eddd0831ba4e827ab67ee2f61ee963cb98788ad4a7ca9d03f921031ff6
+DIST daq-2.0.0.tar.gz 480030 SHA256 fbafc8e362a96fcadc69731f91203ef90845507aae0a4774d5c2825e9d2c1c38 SHA512 aa79e06473592c0ee57a3a2da60f01f35e6268a126fcb3a992ee7c6da48a079cf359db7439be3778997e774c340630d768712c9efea10c570feb4961f9a00b3c WHIRLPOOL c1eb41df6718a7ece0da95599f78f080a32337a3522181ad31db46a0285d584dfd46e2fffce5e73ef3ba0409bd033b59ac0b272df1d7ee104f6160edc69bc8be
+DIST daq-2.0.2.tar.gz 474447 SHA256 d65d1e67c4994e02c3142c49a648642e780b7e3d942b4a51f605309beac269a8 SHA512 b2a47e174155f21cb1c6f1e1c431ea7cca6aa9f7371228e77def3c526a67fd42d0e26e4c94263195e041b203cdf0c2aaef14f9035afb23dde0bd5df3bf422cbd WHIRLPOOL 3902ccda294c5967c509971abbbfb787f46792cd6bc286097e1d8b88c5d0f25c29019c918d41cabb8d52e4fcb1d99ae60e6eea3319aea2ee46aa8aa9b117e738
diff --git a/net-libs/daq/daq-0.6.2-r1.ebuild b/net-libs/daq/daq-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..b405df12296c
--- /dev/null
+++ b/net-libs/daq/daq-0.6.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="Data Acquisition library, for packet I/O"
+HOMEPAGE="http://www.snort.org/"
+SRC_URI="http://www.snort.org/downloads/1339 -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6 +afpacket +dump +pcap nfq ipq static-libs"
+
+DEPEND="pcap? ( >=net-libs/libpcap-1.0.0 )
+ dump? ( >=net-libs/libpcap-1.0.0 )
+ nfq? ( dev-libs/libdnet
+ >=net-firewall/iptables-1.4.10
+ net-libs/libnetfilter_queue )
+ ipq? ( dev-libs/libdnet
+ >=net-firewall/iptables-1.4.10
+ net-libs/libnetfilter_queue )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable pcap pcap-module) \
+ $(use_enable afpacket afpacket-module) \
+ $(use_enable dump dump-module) \
+ $(use_enable nfq nfq-module) \
+ $(use_enable ipq ipq-module) \
+ $(use_enable static-libs static) \
+ --disable-ipfw-module \
+ --disable-bundled-modules
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog README
+
+ # Remove unneeded .la files
+ rm \
+ "${D}"usr/$(get_libdir)/daq/*.la \
+ "${D}"usr/$(get_libdir)/libdaq*.la \
+ "${D}"usr/$(get_libdir)/libsfbpf.la \
+ || die
+
+ # If not using static-libs don't install the static libraries
+ # This has been bugged upstream
+ if ! use static-libs; then
+ for z in libdaq_static libdaq_static_modules; do
+ rm "${D}"usr/$(get_libdir)/${z}.a
+ done
+ fi
+}
+
+pkg_postinst() {
+ einfo "The Data Acquisition library (DAQ) for packet I/O replaces direct"
+ einfo "calls to PCAP functions with an abstraction layer that facilitates"
+ einfo "operation on a variety of hardware and software interfaces without"
+ einfo "requiring changes to application such as Snort."
+ einfo
+ einfo "Please see the README file for DAQ for information about specific"
+ einfo "DAQ modules."
+}
diff --git a/net-libs/daq/daq-0.6.2.ebuild b/net-libs/daq/daq-0.6.2.ebuild
new file mode 100644
index 000000000000..85723a6c97ef
--- /dev/null
+++ b/net-libs/daq/daq-0.6.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="Data Acquisition library, for packet I/O"
+HOMEPAGE="http://www.snort.org/"
+SRC_URI="http://www.snort.org/downloads/1339 -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~mips ~ppc x86"
+IUSE="ipv6 +afpacket +dump +pcap nfq ipq static-libs"
+
+DEPEND="pcap? ( >=net-libs/libpcap-1.0.0 )
+ dump? ( >=net-libs/libpcap-1.0.0 )
+ nfq? ( dev-libs/libdnet
+ >=net-firewall/iptables-1.4.10
+ net-libs/libnetfilter_queue )
+ ipq? ( dev-libs/libdnet
+ >=net-firewall/iptables-1.4.10
+ net-libs/libnetfilter_queue )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable pcap pcap-module) \
+ $(use_enable afpacket afpacket-module) \
+ $(use_enable dump dump-module) \
+ $(use_enable nfq nfq-module) \
+ $(use_enable ipq ipq-module) \
+ $(use_enable static-libs static) \
+ --disable-ipfw-module \
+ --disable-bundled-modules
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog README
+
+ # Remove unneeded .la files
+ for x in pcap afpacket dump nfq ipq; do
+ rm "${D}"usr/lib64/daq/daq_${x}.la
+ done
+ for y in libdaq libdaq_static libdaq_static_modules libsfbpf; do
+ rm "${D}"usr/lib64/${y}.la
+ done
+
+ # If not using static-libs don't install the static libraries
+ # This has been bugged upstream
+ if ! use static-libs; then
+ for z in libdaq_static libdaq_static_modules; do
+ rm "${D}"usr/lib64/${z}.a
+ done
+ fi
+}
+
+pkg_postinst() {
+ einfo "The Data Acquisition library (DAQ) for packet I/O replaces direct"
+ einfo "calls to PCAP functions with an abstraction layer that facilitates"
+ einfo "operation on a variety of hardware and software interfaces without"
+ einfo "requiring changes to application such as Snort."
+ einfo
+ einfo "Please see the README file for DAQ for information about specific"
+ einfo "DAQ modules."
+}
diff --git a/net-libs/daq/daq-2.0.0.ebuild b/net-libs/daq/daq-2.0.0.ebuild
new file mode 100644
index 000000000000..27a503142d2b
--- /dev/null
+++ b/net-libs/daq/daq-2.0.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="Data Acquisition library, for packet I/O"
+HOMEPAGE="http://www.snort.org/"
+SRC_URI="http://www.snort.org/downloads/2311 -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6 +afpacket +dump +pcap nfq ipq static-libs"
+
+DEPEND="pcap? ( >=net-libs/libpcap-1.0.0 )
+ dump? ( >=net-libs/libpcap-1.0.0 )
+ nfq? ( dev-libs/libdnet
+ >=net-firewall/iptables-1.4.10
+ net-libs/libnetfilter_queue )
+ ipq? ( dev-libs/libdnet
+ >=net-firewall/iptables-1.4.10
+ net-libs/libnetfilter_queue )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable pcap pcap-module) \
+ $(use_enable afpacket afpacket-module) \
+ $(use_enable dump dump-module) \
+ $(use_enable nfq nfq-module) \
+ $(use_enable ipq ipq-module) \
+ $(use_enable static-libs static) \
+ --disable-ipfw-module \
+ --disable-bundled-modules
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog README
+
+ # Remove unneeded .la files
+ rm \
+ "${D}"usr/$(get_libdir)/daq/*.la \
+ "${D}"usr/$(get_libdir)/libdaq*.la \
+ "${D}"usr/$(get_libdir)/libsfbpf.la \
+ || die
+
+ # If not using static-libs don't install the static libraries
+ # This has been bugged upstream
+ if ! use static-libs; then
+ for z in libdaq_static libdaq_static_modules; do
+ rm "${D}"usr/$(get_libdir)/${z}.a
+ done
+ fi
+}
+
+pkg_postinst() {
+ einfo "The Data Acquisition library (DAQ) for packet I/O replaces direct"
+ einfo "calls to PCAP functions with an abstraction layer that facilitates"
+ einfo "operation on a variety of hardware and software interfaces without"
+ einfo "requiring changes to application such as Snort."
+ einfo
+ einfo "Please see the README file for DAQ for information about specific"
+ einfo "DAQ modules."
+}
diff --git a/net-libs/daq/daq-2.0.2.ebuild b/net-libs/daq/daq-2.0.2.ebuild
new file mode 100644
index 000000000000..6bd73f786a13
--- /dev/null
+++ b/net-libs/daq/daq-2.0.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib autotools
+
+DESCRIPTION="Data Acquisition library, for packet I/O"
+HOMEPAGE="http://www.snort.org/"
+SRC_URI="http://www.snort.org/downloads/2778 -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6 +afpacket +dump +pcap nfq ipq static-libs"
+
+PCAP_DEPEND=">=net-libs/libpcap-1.0.0"
+IPT_DEPEND="
+ >=net-firewall/iptables-1.4.10
+ dev-libs/libdnet
+ net-libs/libnetfilter_queue
+
+"
+DEPEND="
+ dump? ( ${PCAP_DEPEND} )
+ ipq? ( ${IPT_DEPEND} )
+ nfq? ( ${IPT_DEPEND} )
+ pcap? ( ${PCAP_DEPEND} )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-parallel-grammar.patch #511892
+ epatch "${FILESDIR}"/${P}-libpcap-check.patch
+ eautoreconf
+}
+
+src_configure() {
+ # We forced libpcap to 1.x, so we can set this cache var so
+ # cross-compiling doesn't break on us.
+ daq_cv_libpcap_version_1x=yes \
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable pcap pcap-module) \
+ $(use_enable afpacket afpacket-module) \
+ $(use_enable dump dump-module) \
+ $(use_enable nfq nfq-module) \
+ $(use_enable ipq ipq-module) \
+ $(use_enable static-libs static) \
+ --disable-ipfw-module \
+ --disable-bundled-modules
+}
+
+DOCS=( ChangeLog README )
+
+src_install() {
+ default
+
+ prune_libtool_files
+
+ # If not using static-libs don't install the static libraries
+ # This has been bugged upstream
+ if ! use static-libs; then
+ for z in libdaq_static libdaq_static_modules; do
+ rm "${D}"usr/$(get_libdir)/${z}.a
+ done
+ fi
+}
+
+pkg_postinst() {
+ einfo "The Data Acquisition library (DAQ) for packet I/O replaces direct"
+ einfo "calls to PCAP functions with an abstraction layer that facilitates"
+ einfo "operation on a variety of hardware and software interfaces without"
+ einfo "requiring changes to application such as Snort."
+ einfo
+ einfo "Please see the README file for DAQ for information about specific"
+ einfo "DAQ modules."
+}
diff --git a/net-libs/daq/files/daq-2.0.2-libpcap-check.patch b/net-libs/daq/files/daq-2.0.2-libpcap-check.patch
new file mode 100644
index 000000000000..b68a8a4865f1
--- /dev/null
+++ b/net-libs/daq/files/daq-2.0.2-libpcap-check.patch
@@ -0,0 +1,36 @@
+fix the libpcap check so that people can set the cache version when cross-compiling
+
+patch by Shawn Wallace <sjwallace@google.com>
+
+--- a/m4/sf.m4
++++ b/m4/sf.m4
+@@ -135,7 +135,7 @@
+ echo
+ exit 1
+ fi
+- AC_MSG_CHECKING([for libpcap version >= $1])
++ AC_CACHE_CHECK([for libpcap version >= $1], [daq_cv_libpcap_version_1x], [
+ AC_RUN_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[
+@@ -147,16 +147,13 @@
+ if (strcmp(pcap_version, $1) < 0)
+ return 1;
+ ]])],
+- [libpcap_version_1x="yes"],
+- [libpcap_version_1x="no"])
+- if test "x$libpcap_version_1x" = "xno"; then
+- AC_MSG_RESULT(no)
++ [daq_cv_libpcap_version_1x="yes"],
++ [daq_cv_libpcap_version_1x="no"])])
++ if test "x$daq_cv_libpcap_version_1x" = "xno"; then
+ echo
+ echo " ERROR! Libpcap library version >= $1 not found."
+ echo " Get it from http://www.tcpdump.org"
+ echo
+ exit 1
+- else
+- AC_MSG_RESULT(yes)
+ fi
+ ])
+
diff --git a/net-libs/daq/files/daq-2.0.2-parallel-grammar.patch b/net-libs/daq/files/daq-2.0.2-parallel-grammar.patch
new file mode 100644
index 000000000000..42e0f93791ac
--- /dev/null
+++ b/net-libs/daq/files/daq-2.0.2-parallel-grammar.patch
@@ -0,0 +1,39 @@
+https://bugs.gentoo.org/511892
+
+the scanner needs the generated header file, so make sure it's listed as a
+dependency. else you see a failure:
+ $ cd sfbpf
+ $ make clean
+ $ make sf_scanner.lo
+ <missing tokdefs.h>
+we'd like to list it as a dep of the object, but automake can use generated
+file names, so it's not easy to list that.
+
+we can't have both of the outputs from grammar.y run the lex, otherwise we
+hit random parallel build failures:
+ $ cd sfbpf
+ $ make clean
+ $ make tokdefs.h sf_grammar.c -j
+ <run yacc twice & fail>
+
+--- a/sfbpf/Makefile.am
++++ b/sfbpf/Makefile.am
+@@ -43,14 +43,16 @@
+ libsfbpf_la_LDFLAGS = -version-info 0:1:0 @XCCFLAGS@
+
+ # use of $@ and $< here is a GNU idiom that borks BSD
+-${builddir}/sf_scanner.c: ${srcdir}/scanner.l
++${builddir}/sf_scanner.c: ${srcdir}/scanner.l ${builddir}/tokdefs.h
+ @rm -f ${builddir}/sf_scanner.c
+ ${srcdir}/runlex.sh $(V_LEX) -osf_scanner.c ${srcdir}/scanner.l
+
+-${builddir}/tokdefs.h ${builddir}/sf_grammar.c: ${srcdir}/grammar.y
++${builddir}/sf_grammar.c: ${srcdir}/grammar.y
+ @rm -f ${builddir}/sf_grammar.c ${builddir}/tokdefs.h
+ $(V_YACC) -d ${srcdir}/grammar.y
+ mv y.tab.c sf_grammar.c
+ mv y.tab.h tokdefs.h
+
++${builddir}/tokdefs.h: ${builddir}/sf_grammar.c ; @true
++
+ CLEANFILES = ${builddir}/sf_scanner.c ${builddir}/sf_grammar.c ${builddir}/tokdefs.h ${builddir}/sf_scanner.h
diff --git a/net-libs/daq/metadata.xml b/net-libs/daq/metadata.xml
new file mode 100644
index 000000000000..877529260333
--- /dev/null
+++ b/net-libs/daq/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>jason.r.wallace@gmail.com</email>
+ <name>Jason Wallace</name>
+</maintainer>
+<maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+</maintainer>
+<herd>netmon</herd>
+<longdescription>Data Acquisition library, for packet I/O with Snort 2.9 and later</longdescription>
+<use>
+ <flag name='afpacket'>
+ Build the AFPacket data acquisition module. Functions similar to the PCAP
+ module but with better performance. Snort can run unprivileged when using
+ this module. AFpacket supports both inline and passive modes.
+ </flag>
+ <flag name='dump'>Build the Dump data acquisition module. The dump DAQ
+ allows you to test the various inline mode features available in
+ 2.9 Snort like injection and normalization.
+ </flag>
+ <flag name='pcap'>Build the PCAP data acquisition module.</flag>
+ <flag name='nfq'>
+ Build the NFQ data acquisition module. NFQ is the new way to process iptables
+ packets for inline deployments. Snort can not run unprivileged when using this module.
+ </flag>
+ <flag name='ipq'>
+ Build the IPQ data acquisition module. IPQ is the old way to process iptables
+ packets for inline deployments. Snort can not run unprivileged when using this module.
+ </flag>
+</use>
+</pkgmetadata>
+