summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2023-06-27 13:02:50 +0300
committerSergey Popov <pinkbyte@gentoo.org>2023-06-27 13:05:47 +0300
commit56de063b6822f969abf805834c7ca2ac8b00e203 (patch)
tree6c924f5149631a8e7c936ae0f6f082c84be131d9 /net-dialup
parentprofiles: unmask ffmpeg-6 (diff)
downloadgentoo-56de063b6822f969abf805834c7ca2ac8b00e203.tar.gz
gentoo-56de063b6822f969abf805834c7ca2ac8b00e203.tar.bz2
gentoo-56de063b6822f969abf805834c7ca2ac8b00e203.zip
net-dialup/accel-ppp: version bump
Migrate to linux-mod-r1 eclass Sync live ebuild Closes: https://bugs.gentoo.org/show_bug.cgi?id=907828 Closes: https://bugs.gentoo.org/show_bug.cgi?id=908702 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/accel-ppp/Manifest1
-rw-r--r--net-dialup/accel-ppp/accel-ppp-1.12.0_p20230609.ebuild113
-rw-r--r--net-dialup/accel-ppp/accel-ppp-9999.ebuild27
3 files changed, 126 insertions, 15 deletions
diff --git a/net-dialup/accel-ppp/Manifest b/net-dialup/accel-ppp/Manifest
index 0a3a23ae9261..1156565a8c2f 100644
--- a/net-dialup/accel-ppp/Manifest
+++ b/net-dialup/accel-ppp/Manifest
@@ -1 +1,2 @@
DIST accel-ppp-1.12.0_p20220830.tar.bz2 1667889 BLAKE2B a6432e29953214202dc67822f358c12ade36eda3e1aaa24e8a2f427ac00ae8192216c76620f3c2946bcf88c95f6167ae9c27ce4a1895c36232110cd73c575a36 SHA512 f6e0baf7dcbf66d3d9eadffeb33216d73d6aa9eef461487d51a3811f042229b38bfec5f192742eb51cc7cfedd0a64ad02a3431bfac91ae37a9aab8c910fdcfa4
+DIST accel-ppp-1.12.0_p20230609.tar.bz2 1679570 BLAKE2B 3af713135f755215dc6cd4484ca02f182a17c5240b0b6edf2627412391396ccc1de41dc0098b10e2359ea6d9737c6ff177dc753209a50bdc6989103332453d93 SHA512 c78b8accf74e0f047a9c07b1259f18c7cba3a4e5ecdc594bb4fde4bbbc7b33eeac28265da879bdb17f935628f58f0828eebac0e08ec8ca079ac95911e3851ac2
diff --git a/net-dialup/accel-ppp/accel-ppp-1.12.0_p20230609.ebuild b/net-dialup/accel-ppp/accel-ppp-1.12.0_p20230609.ebuild
new file mode 100644
index 000000000000..a1ae8dea417b
--- /dev/null
+++ b/net-dialup/accel-ppp/accel-ppp-1.12.0_p20230609.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-1 )
+MODULES_OPTIONAL_IUSE="ipoe"
+inherit cmake flag-o-matic linux-mod-r1 lua-single
+
+DESCRIPTION="High performance PPTP, PPPoE and L2TP server"
+HOMEPAGE="https://sourceforge.net/projects/accel-ppp/"
+SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc libtomcrypt lua postgres radius shaper snmp valgrind"
+
+RDEPEND="!libtomcrypt? ( dev-libs/openssl:0= )
+ libtomcrypt? ( dev-libs/libtomcrypt:0= )
+ lua? ( ${LUA_DEPS} )
+ postgres? ( dev-db/postgresql:* )
+ snmp? ( net-analyzer/net-snmp )
+ dev-libs/libpcre"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+PDEPEND="net-dialup/ppp-scripts"
+
+DOCS=( README )
+
+CONFIG_CHECK="~L2TP ~PPPOE ~PPTP"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ valgrind? ( debug )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.11.1-socklen.patch"
+)
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ linux-mod-r1_pkg_setup
+ set_arch_to_kernel
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e "/mkdir/d" \
+ -e "s: RENAME accel-ppp.conf.dist::" accel-pppd/CMakeLists.txt || die 'sed on accel-pppd/CMakeLists.txt failed'
+
+ # Do not install kernel modules like that - breaks sandbox!
+ sed -i -e '/modules_install/d' \
+ drivers/ipoe/CMakeLists.txt \
+ drivers/vlan_mon/CMakeLists.txt || die
+
+ # Fix version
+ sed -i -e "s/1.11/${PV}/" drivers/ipoe/ipoe.c || die
+ sed -i -e "s/1.11/${PV}/" drivers/vlan_mon/vlan_mon.c || die
+
+ # Bug #549918
+ append-ldflags -Wl,-z,lazy
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local libdir="$(get_libdir)"
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+ -DCMAKE_INSTALL_LOCALSTATEDIR="${EPREFIX}/var"
+ -DLIB_SUFFIX="${libdir#lib}"
+ -DBUILD_IPOE_DRIVER="$(usex ipoe)"
+ -DBUILD_PPTP_DRIVER=no
+ -DBUILD_VLAN_MON_DRIVER="$(usex ipoe)"
+ -DCRYPTO="$(usex libtomcrypt TOMCRYPT OPENSSL)"
+ -DLOG_PGSQL="$(usex postgres)"
+ -DLUA="$(usex lua TRUE FALSE)"
+ -DMEMDEBUG="$(usex debug)"
+ -DNETSNMP="$(usex snmp)"
+ -DRADIUS="$(usex radius)"
+ -DSHAPER="$(usex shaper)"
+ $(use debug && echo "-DVALGRIND=$(usex valgrind)")
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ local modlist=( ipoe=accel-ppp:${BUILD_DIR}/drivers/ipoe/driver vlan_mon=accel-ppp:${BUILD_DIR}/drivers/vlan_mon/driver )
+ MODULES_MAKEARGS+=(
+ KDIR="${KV_OUT_DIR}"
+ )
+ linux-mod-r1_src_compile
+ cmake_src_compile
+}
+
+src_install() {
+ linux-mod-r1_src_install
+ cmake_src_install
+
+ use doc && dodoc -r rfc
+
+ if use snmp; then
+ insinto /usr/share/snmp/mibs
+ doins accel-pppd/extra/net-snmp/ACCEL-PPP-MIB.txt
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}d
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}d
+
+ keepdir /var/lib/accel-ppp
+ keepdir /var/log/accel-ppp
+}
diff --git a/net-dialup/accel-ppp/accel-ppp-9999.ebuild b/net-dialup/accel-ppp/accel-ppp-9999.ebuild
index 587d14401f18..82f2ef6bca74 100644
--- a/net-dialup/accel-ppp/accel-ppp-9999.ebuild
+++ b/net-dialup/accel-ppp/accel-ppp-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
LUA_COMPAT=( lua5-1 )
-
EGIT_REPO_URI="https://github.com/accel-ppp/accel-ppp.git"
-inherit cmake flag-o-matic git-r3 linux-info linux-mod lua-single
+MODULES_OPTIONAL_IUSE="ipoe"
+inherit cmake flag-o-matic git-r3 linux-mod-r1 lua-single
DESCRIPTION="High performance PPTP, PPPoE and L2TP server"
HOMEPAGE="https://sourceforge.net/projects/accel-ppp/"
@@ -15,7 +15,7 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="debug doc ipoe libtomcrypt lua postgres radius shaper snmp valgrind"
+IUSE="debug doc libtomcrypt lua postgres radius shaper snmp valgrind"
RDEPEND="!libtomcrypt? ( dev-libs/openssl:0= )
libtomcrypt? ( dev-libs/libtomcrypt:0= )
@@ -35,12 +35,8 @@ REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
valgrind? ( debug )"
pkg_setup() {
- if use ipoe; then
- linux-mod_pkg_setup
- set_arch_to_kernel
- else
- linux-info_pkg_setup
- fi
+ linux-mod-r1_pkg_setup
+ set_arch_to_kernel
use lua && lua-single_pkg_setup
}
@@ -81,15 +77,16 @@ src_configure() {
}
src_compile() {
+ local modlist=( ipoe=accel-ppp:"${BUILD_DIR}/drivers/ipoe/driver" vlan_mon=accel-ppp:"${BUILD_DIR}/drivers/vlan_mon/driver" )
+ MODULES_MAKEARGS+=(
+ KDIR="${KV_OUT_DIR}"
+ )
+ linux-mod-r1_src_compile
cmake_src_compile
}
src_install() {
- if use ipoe; then
- local MODULE_NAMES="ipoe(accel-ppp:${BUILD_DIR}/drivers/ipoe/driver) vlan_mon(accel-ppp:${BUILD_DIR}/drivers/vlan_mon/driver)"
- linux-mod_src_install
- fi
-
+ linux-mod-r1_src_install
cmake_src_install
use doc && dodoc -r rfc