summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/setmixer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/setmixer')
-rw-r--r--media-sound/setmixer/Manifest2
-rw-r--r--media-sound/setmixer/files/setmixer.rc22
-rw-r--r--media-sound/setmixer/metadata.xml5
-rw-r--r--media-sound/setmixer/setmixer-19941227_p1.ebuild39
4 files changed, 68 insertions, 0 deletions
diff --git a/media-sound/setmixer/Manifest b/media-sound/setmixer/Manifest
new file mode 100644
index 000000000000..7c1455aacd0b
--- /dev/null
+++ b/media-sound/setmixer/Manifest
@@ -0,0 +1,2 @@
+DIST setmixer_27DEC94ds1-1.diff.gz 3843 RMD160 100713065cd12ef08561a9b3c4c72861e77d6623 SHA1 5e35dfa3de5972c59edcbac40e1b26e181234389 SHA256 922618c8a35208af81b043c1b4f4e08daab18e753acb20fc1d6837d15c435542
+DIST setmixer_27DEC94ds1.orig.tar.gz 2884 RMD160 16478b59a8a437f5f2d652612f673c112e1685a0 SHA1 34d6cf36b551e4f516f7acc17c190c3446b1457b SHA256 e9a570ecb5e02420414fa2aad650d2efd81587777bbe53b6de38423adb493d03
diff --git a/media-sound/setmixer/files/setmixer.rc b/media-sound/setmixer/files/setmixer.rc
new file mode 100644
index 000000000000..8c71076e7607
--- /dev/null
+++ b/media-sound/setmixer/files/setmixer.rc
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need modules
+ use alsa
+}
+
+start() {
+ ebegin "Loading mixer settings"
+ [ ! -e /etc/setmixer.conf ] && setmixer -V | sed -e 's:-::' > /etc/setmixer.conf
+ setmixer $(cat /etc/setmixer.conf)
+ eend $?
+}
+
+stop() {
+ ebegin "Saving mixer settings"
+ setmixer -V | awk '{print $1" "$3}' > /etc/setmixer.conf
+ eend $?
+}
diff --git a/media-sound/setmixer/metadata.xml b/media-sound/setmixer/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/setmixer/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/setmixer/setmixer-19941227_p1.ebuild b/media-sound/setmixer/setmixer-19941227_p1.ebuild
new file mode 100644
index 000000000000..0df5af5cda66
--- /dev/null
+++ b/media-sound/setmixer/setmixer-19941227_p1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+MY_PV="27DEC94ds1"
+DEB_REV="1"
+
+DESCRIPTION="A commandline mixer"
+HOMEPAGE="http://packages.debian.org/unstable/sound/setmixer"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/s/${PN}/${PN}_${MY_PV}-${DEB_REV}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${MY_PV}.orig
+
+src_unpack() {
+ unpack ${A}
+ epatch "${DISTDIR}"/${PN}_${MY_PV}-${DEB_REV}.diff.gz
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" setmixer || die "emake failed."
+}
+
+src_install() {
+ dobin setmixer
+ dodoc README setmixer.lsm
+ doman setmixer.1
+ insinto /etc
+ doins debian/setmixer.conf
+ newinitd "${FILESDIR}"/setmixer.rc setmixer
+}