summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-09-04 21:22:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-09-04 23:24:29 +0200
commit2b731aedfe2227262bd332dac610180308041a4c (patch)
tree629827c273926b7bcc3e40a9d906bc0df7bc8193 /media-sound/pnmixer
parentmedia-sound/pms: update EAPI 7 -> 8 (diff)
downloadgentoo-2b731aedfe2227262bd332dac610180308041a4c.tar.gz
gentoo-2b731aedfe2227262bd332dac610180308041a4c.tar.bz2
gentoo-2b731aedfe2227262bd332dac610180308041a4c.zip
media-sound/pnmixer: update EAPI 7 -> 8
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/pnmixer')
-rw-r--r--media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild b/media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild
index a76a058cd96f..739d024f7dad 100644
--- a/media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild
+++ b/media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_P="${PN}-v${PV}"
-inherit cmake xdg-utils
+inherit cmake xdg
DESCRIPTION="Volume mixer for the system tray"
HOMEPAGE="https://github.com/nicklan/pnmixer"
SRC_URI="https://github.com/nicklan/${PN}/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
@@ -32,8 +33,6 @@ BDEPEND="
nls? ( sys-devel/gettext )
"
-S="${WORKDIR}/${MY_P}"
-
PATCHES=(
"${FILESDIR}/${P}-fix-assert-if-volume-gt-100.patch"
"${FILESDIR}/${P}-fix-possible-garbage-value.patch"
@@ -49,11 +48,3 @@ src_configure() {
)
cmake_src_configure
}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}