summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-06-18 17:33:19 +0200
committerMarek Szuba <marecki@gentoo.org>2020-06-18 18:29:10 +0200
commitd3af6414bfb05efb9ffdd53c71db287b00bed984 (patch)
tree1a20c5f44d35b34cde830c22d458808c63876a7e /media-gfx/darktable
parentmedia-gfx/darktable: if building with gcc, check for Graphite support (diff)
downloadgentoo-d3af6414bfb05efb9ffdd53c71db287b00bed984.tar.gz
gentoo-d3af6414bfb05efb9ffdd53c71db287b00bed984.tar.bz2
gentoo-d3af6414bfb05efb9ffdd53c71db287b00bed984.zip
media-gfx/darktable-3.0.2*: remove automagic dependency on jsonschema
Darktable build scripts look for the jsonschema executable and if it is found, call it during installation to validate the noise-profile file - with no option available to control this behaviour. dev-python/jsonschema is not a dependency of media-gfx/darktable in my opinion adding it to release ebuilds doesn't make much sense - the noise-profile file is part of the release tarball, if it is bad there is nothing end users can do about it. Bug: https://bugs.gentoo.org/696996 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-gfx/darktable')
-rw-r--r--media-gfx/darktable/darktable-3.0.2-r1.ebuild1
-rw-r--r--media-gfx/darktable/darktable-3.0.2.ebuild1
-rw-r--r--media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch19
3 files changed, 21 insertions, 0 deletions
diff --git a/media-gfx/darktable/darktable-3.0.2-r1.ebuild b/media-gfx/darktable/darktable-3.0.2-r1.ebuild
index 298560b890d0..b864fc88f761 100644
--- a/media-gfx/darktable/darktable-3.0.2-r1.ebuild
+++ b/media-gfx/darktable/darktable-3.0.2-r1.ebuild
@@ -71,6 +71,7 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}"/"${PN}"-find-opencl-header.patch
"${FILESDIR}"/${PN}-3.0.2_cmake-opencl-kernel-loop.patch
+ "${FILESDIR}"/${PN}-3.0.2_jsonschema-automagic.patch
)
S="${WORKDIR}/${P/_/~}"
diff --git a/media-gfx/darktable/darktable-3.0.2.ebuild b/media-gfx/darktable/darktable-3.0.2.ebuild
index 1ab8842d12a2..c0116fa643b7 100644
--- a/media-gfx/darktable/darktable-3.0.2.ebuild
+++ b/media-gfx/darktable/darktable-3.0.2.ebuild
@@ -71,6 +71,7 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}"/"${PN}"-find-opencl-header.patch
"${FILESDIR}"/${PN}-3.0.2_cmake-opencl-kernel-loop.patch
+ "${FILESDIR}"/${PN}-3.0.2_jsonschema-automagic.patch
)
S="${WORKDIR}/${P/_/~}"
diff --git a/media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch b/media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch
new file mode 100644
index 000000000000..1aa0aec5163f
--- /dev/null
+++ b/media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch
@@ -0,0 +1,19 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -319,15 +319,7 @@
+ message(STATUS "Test-compilation of OpenCL programs is disabled.")
+ endif()
+
+-# we need jsonschema to check noiseprofiles.json
+-find_program(jsonschema_BIN jsonschema)
+-if(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
+- message(STATUS "Missing jsonschema, problems in noiseprofiles.json might go unnoticed")
+- set(VALIDATE_JSON 0)
+-else(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
+- message(STATUS "Found jsonschema")
+- set(VALIDATE_JSON 1)
+-endif(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
++set(VALIDATE_JSON 0)
+
+ # we need an xslt interpreter to generate preferences_gen.h and darktablerc
+ find_program(Xsltproc_BIN xsltproc)