summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-03-07 22:12:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 23:45:46 +0100
commit18e50be7ebec9b7dadfa10861a5e7df4b3508c28 (patch)
tree42a6df5f2f7e31f06b08a90121f341ff64d7865b /lxqt-base/lxqt-qtplugin
parentlxqt-base/lxqt-powermanagement: version bump to 0.14.1 (diff)
downloadgentoo-18e50be7ebec9b7dadfa10861a5e7df4b3508c28.tar.gz
gentoo-18e50be7ebec9b7dadfa10861a5e7df4b3508c28.tar.bz2
gentoo-18e50be7ebec9b7dadfa10861a5e7df4b3508c28.zip
lxqt-base/lxqt-qtplugin: version bump to 0.14.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-qtplugin')
-rw-r--r--lxqt-base/lxqt-qtplugin/Manifest1
-rw-r--r--lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.14.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-qtplugin/Manifest b/lxqt-base/lxqt-qtplugin/Manifest
index 4142c269d4b1..459144b1c727 100644
--- a/lxqt-base/lxqt-qtplugin/Manifest
+++ b/lxqt-base/lxqt-qtplugin/Manifest
@@ -1 +1,2 @@
DIST lxqt-qtplugin-0.13.0.tar.xz 23888 BLAKE2B 564a88cb04416b078e0c415efcb78be7acb7d3fa703bf4c30d75cb0e4aba00b443e021f6d37f9fcc983233824a71cd9b15c45b14579310ce9b3b89a2a1d88c5c SHA512 22f059accdca8216b80af8773eab462c779c489575aa7802e82bb95da4f22a9a0d5a1234b2da4cb39c5050a6e9ded3c2b977068cc37af356ecb09e364633c7d6
+DIST lxqt-qtplugin-0.14.0.tar.xz 22336 BLAKE2B 8155722880cff279aa26676ed425a011b2259ba94bf92122c59643a0ac6dd89b2841bcbeeac26ac24ef1e351dcdbcabf339c4a2bcee2dac30f2f9298434f7294 SHA512 33188bc03ee48a9b6e3cc5823cdcb5c96dba0cda65da511fe603d952c5de24e292cb02208cf357b04718df90f98d53bf48eaf6793d70d043214e429f57ccf53c
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.14.0.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.14.0.ebuild
new file mode 100644
index 000000000000..a4c000ea278b
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.14.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+"
+DEPEND="
+ dev-libs/libdbusmenu-qt:=[qt5(+)]
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ =x11-libs/libfm-qt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}"