summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-31 15:35:17 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-31 15:35:17 +0100
commite09ee8c07e6739e5133b6a67f305aebabac9dd27 (patch)
tree1570eb17cf01238060d339226650a92282201ed1 /kde-plasma/ksshaskpass
parentmedia-libs/openh264: Restrict nasm dep to x86 ABIs which are the only one nee... (diff)
downloadgentoo-e09ee8c07e6739e5133b6a67f305aebabac9dd27.tar.gz
gentoo-e09ee8c07e6739e5133b6a67f305aebabac9dd27.tar.bz2
gentoo-e09ee8c07e6739e5133b6a67f305aebabac9dd27.zip
kde-plasma: Version bump KDE Plasma 5.9.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.9.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 3e31bd770ec6..927a0806375e 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST 50971-ksshaskpass-0.5.3.tar.gz 11010 SHA256 a3a47eba74a52ec3d9d8740ed9a29a5aa852d4e268b5d81154f85b90258a2124 SHA512 0274b58fb9dbb634688e5ee8b22a88012483907769796733c79f8e3c115463702a9cdd787d49d0b94a7942f5f88ed3465a6161d6e4516711b2bba5c47a91fa50 WHIRLPOOL d3e68640d3e0049bdd071fe72bf0bd9767bf349c94b2fbb42e7fafe6259d895ec2d5122ae9477e66073c53cbbda704ec0237328dd948b21207b2db2b39946450
DIST ksshaskpass-5.8.5.tar.xz 19456 SHA256 b0abeaba2a3eff16e233e047b41c20bf4065b4529e706929f4c0e6a9884324bf SHA512 0ab10f04fea8d97bb7e942cfd11563d22e065e19414aad2484e5b1661ed7b492d769da69b30eeed9e392ef75a3cc518e0a8005fe5afb84dfc6192ad9a4c0bc8b WHIRLPOOL 19c08e63ef15f0e5a38cc10d02f71e3bb616ec7d219f06cf1004af9789832a6e2a031548ef78790f67a46bf5e69b076dc2d7082ba25b6c39621eaa97a9113546
+DIST ksshaskpass-5.9.0.tar.xz 19396 SHA256 75a98037ed29ececc7254e9772a2835c80a9bd7d9ecf65b933137b1e4cfa8d9c SHA512 14eb96a95e042e4403268144b78aa8dfcb31f9c57bae308a9fe3b6ac1608fb4945479369dc945e95835c0965ba3dbb141685a7e999136ccc13c2ce24de1dfa7d WHIRLPOOL 48f58e5ec0468493a7f40b267415769da0aafa36499d88b7671a6a2ed83ddac55df1725adbde6f2958c091414b6fd584de5b1d11f45a60d4ca057ff30f5c0a09
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.9.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.9.0.ebuild
new file mode 100644
index 000000000000..37e0a49e1497
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.9.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/ksshaskpass"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}