summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-06 16:04:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-06 17:06:07 +0200
commit8ea97068f86f7c38eb7eba7b4834d24395ea63c8 (patch)
tree1a99302b57a044d70ab6ffc235920f12cd030996 /kde-apps/pimcommon
parentdev-texlive/texlive-luatex: Add more blockers (diff)
downloadgentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.tar.gz
gentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.tar.bz2
gentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.zip
kde-apps: Add KDE Applications 19.04.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'kde-apps/pimcommon')
-rw-r--r--kde-apps/pimcommon/Manifest1
-rw-r--r--kde-apps/pimcommon/pimcommon-19.04.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-apps/pimcommon/Manifest b/kde-apps/pimcommon/Manifest
index ca4cdc658147..dbbdc98e1725 100644
--- a/kde-apps/pimcommon/Manifest
+++ b/kde-apps/pimcommon/Manifest
@@ -1,2 +1,3 @@
DIST pimcommon-18.12.3.tar.xz 295052 BLAKE2B 145329d4fec3b393a1d0b19d54871e9333823e905be491e49f37a5c76b26362100b356780a978a346feb18e27d4422ff77561eb61436683b5c996c335e04f722 SHA512 261c84c206ae9ddea9aff3c0f79436a8c32d060ee018aa7e02c698596a106ba608cacf1198b1b4d0f3df41c301ddeddb6bd6c4e344721ff616d0d0c6dd3fc7f8
DIST pimcommon-19.04.1.tar.xz 295656 BLAKE2B 91321a95608a822f6ea941bd72695f0f716b7b18c9cf670fe28479277bc19c56e02339a58eaeb23f3c632d640d0eb72a8c626898ba8d81a30c0cd8e05bdd78f8 SHA512 713781a39152e21400f28ee648f7155dbb7b1d20dc140db002043fa3ad0c90f93f13615af244f98357251a28d8e2ef50565229b5fbda1abb6b783b63f7977650
+DIST pimcommon-19.04.2.tar.xz 295112 BLAKE2B 9386edf4d8fd757efa63dcd547d3a5faa7d7eeaeaaad059c3d040a9ce898ae97d081c2a1927a665bc1a29e3f63c870f340053c31ccb064c30918543812a191f7 SHA512 5c9b3c0e4ea0336a18e8853377e077db96ae090606d3b35f137270d74d5bb496ad9f21b94373d047395529a1e43ce6914c95c559c69bc28c9f7a6f5b322be5ca
diff --git a/kde-apps/pimcommon/pimcommon-19.04.2.ebuild b/kde-apps/pimcommon/pimcommon-19.04.2.ebuild
new file mode 100644
index 000000000000..f6917eeb6a78
--- /dev/null
+++ b/kde-apps/pimcommon/pimcommon-19.04.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Common PIM libraries"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="share"
+
+BDEPEND="
+ dev-libs/libxslt
+"
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kpimtextedit)
+ $(add_kdeapps_dep libkdepim)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/grantlee:5
+ share? ( $(add_frameworks_dep purpose) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kiconthemes)
+ test? ( $(add_kdeapps_dep kmime) )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-common-libs:4
+ !kde-apps/kdepim-l10n
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package share KF5Purpose)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # bugs 641730, 661330
+ local myctestargs=(
+ -E "(autocorrectiontest|pimcommon-translator-translatortest)"
+ )
+
+ kde5_src_test
+}