summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:53:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit44068399ad98520a66cafb092af777af8d77a11e (patch)
tree41ec18453e7fe581c9f6020280baaa81ae0a167d /kde-apps/kimap
parentkde-frameworks: Add KDE Frameworks 5.50.0 (diff)
downloadgentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.gz
gentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.bz2
gentoo-44068399ad98520a66cafb092af777af8d77a11e.zip
kde-apps: Add KDE Applications 18.08.1
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-apps/kimap')
-rw-r--r--kde-apps/kimap/Manifest1
-rw-r--r--kde-apps/kimap/kimap-18.08.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/kde-apps/kimap/Manifest b/kde-apps/kimap/Manifest
index d5cb3ebf4cfc..f43771d22954 100644
--- a/kde-apps/kimap/Manifest
+++ b/kde-apps/kimap/Manifest
@@ -1 +1,2 @@
DIST kimap-18.04.3.tar.xz 119332 BLAKE2B f235a3ffc973bdf3ca27eba494b279c4ae2cc9b5eec8bc2b8597667fdc3e2d2fc4f9c97a0437001a13c770f498480e0945f85aedd0f9c00b20aa4b027650dd02 SHA512 a17e4132a3c0d698eda715fa7ebcc5d7d4e16b9ad8aefab25bc3d91a64200504fdfcf034d42929f56c0b26ee90ad8b068e58b7bac1d2a3934ae5757de4c3b966
+DIST kimap-18.08.1.tar.xz 119812 BLAKE2B 83683413a18f272d3942544370cb70df30f1c7a0cfd6370de16175efb3bab5d2e811582014abbbcd1f1c7d5f11e0e7442924907c2a1c2dff164395eb63a53901 SHA512 02a6d16eb921c6bdc5ee30bf92754cdbf2188b222bdc5dd62acff9f9f073cbd8f97207d434ba49538e75024b7fdf036dfb244738b4e64994ab8d78456cead827
diff --git a/kde-apps/kimap/kimap-18.08.1.ebuild b/kde-apps/kimap/kimap-18.08.1.ebuild
new file mode 100644
index 000000000000..e7bcd2eec264
--- /dev/null
+++ b/kde-apps/kimap/kimap-18.08.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for interacting with IMAP servers"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# TODO: Convince upstream not to install stuff with tests
+CDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtgui)
+ dev-libs/cyrus-sasl
+"
+DEPEND="${CDEPEND}
+ test? ( $(add_qt_dep qttest) )
+"
+RDEPEND="${CDEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_test() {
+ # tests cannot be run in parallel #605586
+ local myctestargs=(
+ -j1
+ )
+
+ kde5_src_test
+}