summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-12-30 08:39:06 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-01-20 16:13:39 +0200
commitb7d4b2d7cb6b2956e46cfb4654b8b5442e1b1b09 (patch)
treed0d1eec49c51c60ee6fc572bf59dc6b603f82982 /games-util
parentnet-im/telegram-desktop-bin: cleanup old (diff)
downloadgentoo-b7d4b2d7cb6b2956e46cfb4654b8b5442e1b1b09.tar.gz
gentoo-b7d4b2d7cb6b2956e46cfb4654b8b5442e1b1b09.tar.bz2
gentoo-b7d4b2d7cb6b2956e46cfb4654b8b5442e1b1b09.zip
games-util/deutex: Version bump to 5.2.2
Closes: https://bugs.gentoo.org/762652 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18882 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/deutex/Manifest1
-rw-r--r--games-util/deutex/deutex-5.2.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/games-util/deutex/Manifest b/games-util/deutex/Manifest
index 80a384510e14..4d44f3860e0e 100644
--- a/games-util/deutex/Manifest
+++ b/games-util/deutex/Manifest
@@ -1 +1,2 @@
DIST deutex-5.2.0.tar.xz 165772 BLAKE2B 4451e6abc13d3d6e9176a5d8aad6a5d3d986b2b280b2094d89876ec9bea68db5aa9179f8d650932499a2f8853fb57644f723e4214f5a973f217ef34e236e57a9 SHA512 5baa3e06e8562e36e9e520a52a7b4407277e7741deb543eb7b68587a9aab3f409c574415654e8a1ef15d2afb7750aa603189f8de749353666295c6a292b92a33
+DIST deutex-5.2.2.tar.zst 172022 BLAKE2B ad290ce6792425ba7f643cfe6c09c1a3f040ad0a4c95822f9368592dde6d489d28e892a26d78f2ebfefa086c910c948ef37eb3a3047429605653b273f9b567a8 SHA512 5f3c3d3ecad3a7949270a10c3c7e3a8be938389d4846dcac171526a9fd0485e056889323d303f61630e8735e5735edc91df7ad4efaba3d0b2b66a9d719017ebc
diff --git a/games-util/deutex/deutex-5.2.2.ebuild b/games-util/deutex/deutex-5.2.2.ebuild
new file mode 100644
index 000000000000..dcead660a3ae
--- /dev/null
+++ b/games-util/deutex/deutex-5.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="WAD composer for Doom, Heretic, Hexen, and Strife"
+HOMEPAGE="https://github.com/Doom-Utils/deutex"
+SRC_URI="https://github.com/Doom-Utils/${PN}/releases/download/v${PV}/${P}.tar.zst"
+
+LICENSE="GPL-2+ LGPL-2+ HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="man png"
+
+DEPEND="png? ( media-libs/libpng:0= )"
+RDEPEND="${DEPEND}"
+BDEPEND="man? ( app-text/asciidoc )"
+
+src_configure() {
+ econf \
+ $(use_enable man) \
+ $(use_with png libpng)
+}