summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-24 14:30:10 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-24 14:54:03 +0100
commit8ca1b0e84701b8ef05f44317459352d7c10a0ed5 (patch)
tree46c4785df20d8fcb3aeda9e8031595d9a99b63e0 /games-util
parentgames-util/dfarc: Port to wxGTK 3.2 (diff)
downloadgentoo-8ca1b0e84701b8ef05f44317459352d7c10a0ed5.tar.gz
gentoo-8ca1b0e84701b8ef05f44317459352d7c10a0ed5.tar.bz2
gentoo-8ca1b0e84701b8ef05f44317459352d7c10a0ed5.zip
games-util/wxchtdecoder: works with wxGTK 3.2
And install a proper menu entry Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/wxchtdecoder/wxchtdecoder-1.5a-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-util/wxchtdecoder/wxchtdecoder-1.5a-r2.ebuild b/games-util/wxchtdecoder/wxchtdecoder-1.5a-r2.ebuild
new file mode 100644
index 000000000000..99400f1e5eea
--- /dev/null
+++ b/games-util/wxchtdecoder/wxchtdecoder-1.5a-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit desktop wxwidgets
+
+DESCRIPTION="Program to decode .CHT files in Snes9x and ZSNES to plain text"
+HOMEPAGE="https://games.technoplaza.net/chtdecoder/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND=${RDEPEND}
+
+PATCHES=( "${FILESDIR}"/${P}-wxgtk.patch )
+
+src_configure() {
+ setup-wxwidgets
+ econf --with-wx-config="${WX_CONFIG}"
+}
+
+src_install() {
+ dobin source/wxchtdecoder
+ dodoc docs/wxchtdecoder.txt
+ make_desktop_entry ${PN} wxCHTDecoder application-vnd.nintendo.snes.rom
+}