summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-27 18:41:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-07 20:19:55 +0100
commit284749530391de7e49945d61801ee0ab623d59e7 (patch)
tree40c1b351e4194357707e73576d1379f878e0b071 /games-action/supermariowar/files
parentsci-biology/express: EAPI-7/cmake.eclass, new HOMEPAGE/SRC_URI (diff)
downloadgentoo-284749530391de7e49945d61801ee0ab623d59e7.tar.gz
gentoo-284749530391de7e49945d61801ee0ab623d59e7.tar.bz2
gentoo-284749530391de7e49945d61801ee0ab623d59e7.zip
games-action/supermariowar: EAPI-7 bump, switch to cmake.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-action/supermariowar/files')
-rw-r--r--games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch b/games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch
new file mode 100644
index 000000000000..2ecc26977598
--- /dev/null
+++ b/games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch
@@ -0,0 +1,18 @@
+Fix linking with BUILD_SHARED_LIBS=ON default in EAPI-7
+
+--- a/src/common_netplay/CMakeLists.txt
++++ b/src/common_netplay/CMakeLists.txt
+@@ -1,4 +1,4 @@
+
+ if(NOT NO_NETWORK)
+- add_library(NetplayFiles platform_enet/NetPeerENet.cpp)
++ add_library(NetplayFiles STATIC platform_enet/NetPeerENet.cpp)
+ endif()
+--- a/src/common/CMakeLists.txt
++++ b/src/common/CMakeLists.txt
+@@ -39,4 +39,4 @@
+ list(APPEND COMMON_SRCS src/savepng.cpp)
+ endif()
+
+-add_library(CommonFiles ${COMMON_SRCS})
++add_library(CommonFiles STATIC ${COMMON_SRCS})