summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-10-05 00:33:42 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-10-13 14:21:58 +0300
commitbb4c4617af1a8a7a1786135f4807a3e9d5c2c30e (patch)
treeba72ca4a7d3d33b969a3edde258ab75fee6063c0 /dev-util/smem
parentsci-libs/med: switch to cmake based build (diff)
downloadgentoo-bb4c4617af1a8a7a1786135f4807a3e9d5c2c30e.tar.gz
gentoo-bb4c4617af1a8a7a1786135f4807a3e9d5c2c30e.tar.bz2
gentoo-bb4c4617af1a8a7a1786135f4807a3e9d5c2c30e.zip
dev-util/smem: bump to version 1.4
Closes: https://bugs.gentoo.org/683354 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/smem')
-rw-r--r--dev-util/smem/Manifest1
-rw-r--r--dev-util/smem/metadata.xml21
-rw-r--r--dev-util/smem/smem-1.4.ebuild42
3 files changed, 63 insertions, 1 deletions
diff --git a/dev-util/smem/Manifest b/dev-util/smem/Manifest
index 360f05065df9..deaf11d8e35c 100644
--- a/dev-util/smem/Manifest
+++ b/dev-util/smem/Manifest
@@ -1 +1,2 @@
+DIST smem-1.4.tar.gz 15733 BLAKE2B 6c097c10625050a9d3a133144054d9791bb0ae2f498335398889b58c243b4477d38aefd8203a0483016647a6a72b4bcf4b9af23c241c0e87494614ca6cdaeade SHA512 2740b9ebede8e742e3d01f5f2e7a77a4d3ed04bee78585a904d07c299ea5a77be135dd5b6626abfdebcf2742b9004035443d3faeca04ca9b59c603f74708af9b
DIST smem.pl.20071119_p1.bz2 794 BLAKE2B eb48d3ed41d0261a94381da5795764a78d95abcb23fe9d46755e7c4a6672931a972bca8f188a359b7bb4a52afcfe177098c048e3dddc910a7423f5c2bf5d37ac SHA512 452d10b2e3dda5d4167e62e3fd541f89f90cb07c431876e0fb671f30e224b8cd14a0268ab14243342c2188f3d3826e7a8303b3fd2eda393fdc8e31d0f1b1d575
diff --git a/dev-util/smem/metadata.xml b/dev-util/smem/metadata.xml
index 7a38bb900964..bd732509198c 100644
--- a/dev-util/smem/metadata.xml
+++ b/dev-util/smem/metadata.xml
@@ -1,5 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ A tool that can give numerous reports on memory usage on Linux systems.
+ Unlike existing tools, smem can report proportional set size (PSS),
+ which is a more meaningful representation of the amount of memory
+ used by libraries and applications in a virtual memory system.
+
+ Because large portions of physical memory are typically shared among
+ multiple applications, the standard measure of memory usage known as
+ resident set size (RSS) will significantly overestimate memory usage.
+ PSS instead measures each application's "fair share" of each shared
+ area to give a realistic measure.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-util/smem/smem-1.4.ebuild b/dev-util/smem/smem-1.4.ebuild
new file mode 100644
index 000000000000..2eff0923ad8f
--- /dev/null
+++ b/dev-util/smem/smem-1.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 toolchain-funcs
+
+DESCRIPTION="A tool that can give numerous reports on memory usage on Linux systems"
+HOMEPAGE="https://www.selenic.com/smem/"
+SRC_URI="https://www.selenic.com/${PN}/download/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+BDEPEND="dev-lang/python:2.7"
+
+src_prepare() {
+ default
+
+ python_fix_shebang smem
+}
+
+src_compile() {
+ "$(tc-getCC)" ${CFLAGS} ${LDFLAGS} -o smemcap smemcap.c || die
+}
+
+src_install() {
+ dobin smemcap
+ python_doexe smem
+
+ doman smem.8
+}
+
+pkg_postinst() {
+ optfeature "for chart generation." dev-python/matplotlib
+}