summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-07 06:31:46 +0100
committerSam James <sam@gentoo.org>2022-08-07 06:32:09 +0100
commitcc295391fddf63aec465b58d7aac89e1f72b951c (patch)
tree39a986f3b729be9bc3a9fa635af09b8e18cb9a40 /dev-util/pkgconf
parentnet-im/gajim: add 1.4.7 (diff)
downloadgentoo-cc295391fddf63aec465b58d7aac89e1f72b951c.tar.gz
gentoo-cc295391fddf63aec465b58d7aac89e1f72b951c.tar.bz2
gentoo-cc295391fddf63aec465b58d7aac89e1f72b951c.zip
dev-util/pkgconf: add 1.9.0 (unkeyworded)
Unkeyworded as it's a testing/development release. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/Manifest1
-rw-r--r--dev-util/pkgconf/pkgconf-1.9.0.ebuild69
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild28
3 files changed, 81 insertions, 17 deletions
diff --git a/dev-util/pkgconf/Manifest b/dev-util/pkgconf/Manifest
index 5a9d1dca32cd..c74a2969150f 100644
--- a/dev-util/pkgconf/Manifest
+++ b/dev-util/pkgconf/Manifest
@@ -1 +1,2 @@
DIST pkgconf-1.8.0.tar.xz 296304 BLAKE2B 6585a855a313406f77d26fba3cc3cef798b27c4b7ece81738bdba12f36ee93fbcaf838e1065406c28adc20852e34e2de14bc5f4837982f9cc35360d9a3ac83a5 SHA512 58204006408ad5ce91222ed3c93c2e0b61c04fa83c0a8ad337b747b583744578dbebd4ad5ccbc577689637caa1c5dc246b7795ac46e39c6666b1aa78199b7c28
+DIST pkgconf-1.9.0.tar.xz 306336 BLAKE2B 5e66082ed0d4279eacc5d8428e1243196e446c9346171f78fa693bc028edbe80ba585274e00a4d461a3118bb33845f42b4e54c6a0092a642320a59cf2807cd6a SHA512 14b53b8a5a2e90b62d23c4ca3ea8e6f3113aac1ab4bc63bb59fef27d61d2f13953d02ea022c38ed9aa039b075a9ff93cf9fd58f93013cd1ea78bef411937055a
diff --git a/dev-util/pkgconf/pkgconf-1.9.0.ebuild b/dev-util/pkgconf/pkgconf-1.9.0.ebuild
new file mode 100644
index 000000000000..c63109267d0a
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-1.9.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2012-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://gitea.treehouse.systems/ariadne/pkgconf.git"
+else
+ SRC_URI="https://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
+ # Per release notes, 1.9.0 is a testing/development release.
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://gitea.treehouse.systems/ariadne/pkgconf"
+
+LICENSE="ISC"
+SLOT="0/4"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-libs/atf
+ dev-util/kyua
+ )
+"
+RDEPEND="!dev-util/pkgconfig"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/pkg-config$(get_exeext)
+ )
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-system-includedir="${EPREFIX}/usr/include"
+ --with-system-libdir="${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)"
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
+ default
+}
+
+multilib_src_install() {
+ default
+
+ dosym pkgconf$(get_exeext) /usr/bin/pkg-config$(get_exeext)
+ dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index ecbccf339c73..a889721e17d0 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -1,26 +1,25 @@
# Copyright 2012-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit multilib multilib-minimal
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://gitea.treehouse.systems/ariadne/pkgconf.git"
else
SRC_URI="https://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~ppc-macos ~x64-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
HOMEPAGE="https://gitea.treehouse.systems/ariadne/pkgconf"
LICENSE="ISC"
-SLOT="0/3"
+SLOT="0/4"
IUSE="test"
-# tests require 'kyua'
RESTRICT="!test? ( test )"
BDEPEND="
@@ -29,31 +28,25 @@ BDEPEND="
dev-util/kyua
)
"
-RDEPEND="
- !dev-util/pkgconfig
-"
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/pkgconf$(get_exeext)
-)
+RDEPEND="!dev-util/pkgconfig"
src_prepare() {
default
- [[ ${PV} == "9999" ]] && eautoreconf
+ [[ ${PV} == 9999 ]] && eautoreconf
+
MULTILIB_CHOST_TOOLS+=(
/usr/bin/pkg-config$(get_exeext)
)
}
multilib_src_configure() {
- local ECONF_SOURCE="${S}"
- local args=(
- --disable-static
+ local myeconfargs=(
--with-system-includedir="${EPREFIX}/usr/include"
--with-system-libdir="${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)"
)
- econf "${args[@]}"
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_test() {
@@ -70,5 +63,6 @@ multilib_src_install() {
multilib_src_install_all() {
einstalldocs
+
find "${ED}" -type f -name '*.la' -delete || die
}