summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-24 12:44:05 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-24 14:42:45 -0800
commit574a5327c6c99ff9686f15910af493dabf204b24 (patch)
tree93fa572f9cac35a9f43d42700820a67087db9c6e /dev-util/gdbus-codegen
parentdev-util/devhelp: Drop old versions (diff)
downloadgentoo-574a5327c6c99ff9686f15910af493dabf204b24.tar.gz
gentoo-574a5327c6c99ff9686f15910af493dabf204b24.tar.bz2
gentoo-574a5327c6c99ff9686f15910af493dabf204b24.zip
dev-util/gdbus-codegen: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/gdbus-codegen')
-rw-r--r--dev-util/gdbus-codegen/Manifest2
-rw-r--r--dev-util/gdbus-codegen/gdbus-codegen-2.68.4.ebuild72
-rw-r--r--dev-util/gdbus-codegen/gdbus-codegen-2.70.0.ebuild72
3 files changed, 0 insertions, 146 deletions
diff --git a/dev-util/gdbus-codegen/Manifest b/dev-util/gdbus-codegen/Manifest
index ae9c6147a0ce..d1b77012b4a5 100644
--- a/dev-util/gdbus-codegen/Manifest
+++ b/dev-util/gdbus-codegen/Manifest
@@ -1,3 +1 @@
-DIST glib-2.68.4.tar.xz 4945212 BLAKE2B 2135e2bea778714494b9f3ef140f20639f95dd347c9025e5663ca8f493092cd2723aba6520bb4f85687491794353685eccacc4dd34339962e5cb717e6130c025 SHA512 be17d79b41d17fd2b144184d6e793180667b7d9ba299215ea6d4948b4c05f6d888b4868c48643e25935a34ee2f85ee1d03e53325151b7a61819437cbd3c84b10
-DIST glib-2.70.0.tar.xz 4796812 BLAKE2B de393961c8c2b98fadc1cc0a3647de4fb9d54193e000005c847468e48baa30abcc518d94e1aaa69e09414ee0218c5502f872e08818bcc404aa0c61f94fe2c156 SHA512 fd3fcaebd34aebe0e63f9dc915b2df026a3f88a5c2254e9f17beea0a59ab0ac563976fca54eb57bd2f7af183c4ae76fb86f05951216bf4159d258b5e7b29696f
DIST glib-2.70.2.tar.xz 4822356 BLAKE2B 63b1f4e05f26cd51c3345bb042e2175ebcdb22afa3fef85bccae530581a378070e6c7ea48eb957bcc73142ea228ddb70bdac2679ca2f81155a668560397aaa37 SHA512 872e3f06f87f21a32446b41aac7454fd6bf4d665c753121f6e9772cddebc592b79d88713fc6b8d510636af9f9c4528a9d508d8c4225c6dfeb928390120fb4809
diff --git a/dev-util/gdbus-codegen/gdbus-codegen-2.68.4.ebuild b/dev-util/gdbus-codegen/gdbus-codegen-2.68.4.ebuild
deleted file mode 100644
index cbfb6ebcd040..000000000000
--- a/dev-util/gdbus-codegen/gdbus-codegen-2.68.4.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-GNOME_ORG_MODULE="glib"
-PYTHON_COMPAT=( python3_{7..10} )
-PYTHON_REQ_USE="xml"
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit gnome.org distutils-r1
-
-DESCRIPTION="GDBus code and documentation generator"
-HOMEPAGE="https://www.gtk.org/"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-libs/libxslt
- app-text/docbook-xsl-stylesheets
-"
-
-S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen"
-
-python_prepare_all() {
- PATCHES=(
- "${FILESDIR}/${PN}-2.56.1-sitedir.patch"
- )
- distutils-r1_python_prepare_all
-
- local MAJOR_VERSION=$(ver_cut 1)
- local MINOR_VERSION=$(ver_cut 2)
- sed -e 's:@PYTHON@:python:' gdbus-codegen.in > gdbus-codegen || die
- sed -e "s:@VERSION@:${PV}:" \
- -e "s:@MAJOR_VERSION@:${MAJOR_VERSION}:" \
- -e "s:@MINOR_VERSION@:${MINOR_VERSION}:" config.py.in > config.py || die
- cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
- sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
-}
-
-do_xsltproc_command() {
- # Taken from meson.build for manual manpage building - keep in sync (also copied to dev-util/glib-utils)
- xsltproc \
- --nonet \
- --stringparam man.output.quietly 1 \
- --stringparam funcsynopsis.style ansi \
- --stringparam man.th.extra1.suppress 1 \
- --stringparam man.authors.section.enabled 0 \
- --stringparam man.copyright.section.enabled 0 \
- -o "${2}" \
- http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl \
- "${1}" || die "manpage generation failed"
-}
-
-src_compile() {
- distutils-r1_src_compile
- do_xsltproc_command "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.xml" "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
-}
-
-src_test() {
- einfo "Skipping tests. This package is tested by dev-libs/glib"
- einfo "when merged with FEATURES=test"
-}
-
-python_install_all() {
- distutils-r1_python_install_all # no-op, but prevents QA warning
- doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
-}
diff --git a/dev-util/gdbus-codegen/gdbus-codegen-2.70.0.ebuild b/dev-util/gdbus-codegen/gdbus-codegen-2.70.0.ebuild
deleted file mode 100644
index acef6bad7645..000000000000
--- a/dev-util/gdbus-codegen/gdbus-codegen-2.70.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-GNOME_ORG_MODULE="glib"
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="xml"
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit gnome.org distutils-r1
-
-DESCRIPTION="GDBus code and documentation generator"
-HOMEPAGE="https://www.gtk.org/"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-libs/libxslt
- app-text/docbook-xsl-stylesheets
-"
-
-S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen"
-
-python_prepare_all() {
- PATCHES=(
- "${FILESDIR}/${PN}-2.56.1-sitedir.patch"
- )
- distutils-r1_python_prepare_all
-
- local MAJOR_VERSION=$(ver_cut 1)
- local MINOR_VERSION=$(ver_cut 2)
- sed -e 's:@PYTHON@:python:' gdbus-codegen.in > gdbus-codegen || die
- sed -e "s:@VERSION@:${PV}:" \
- -e "s:@MAJOR_VERSION@:${MAJOR_VERSION}:" \
- -e "s:@MINOR_VERSION@:${MINOR_VERSION}:" config.py.in > config.py || die
- cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
- sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
-}
-
-do_xsltproc_command() {
- # Taken from meson.build for manual manpage building - keep in sync (also copied to dev-util/glib-utils)
- xsltproc \
- --nonet \
- --stringparam man.output.quietly 1 \
- --stringparam funcsynopsis.style ansi \
- --stringparam man.th.extra1.suppress 1 \
- --stringparam man.authors.section.enabled 0 \
- --stringparam man.copyright.section.enabled 0 \
- -o "${2}" \
- http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl \
- "${1}" || die "manpage generation failed"
-}
-
-src_compile() {
- distutils-r1_src_compile
- do_xsltproc_command "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.xml" "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
-}
-
-src_test() {
- einfo "Skipping tests. This package is tested by dev-libs/glib"
- einfo "when merged with FEATURES=test"
-}
-
-python_install_all() {
- distutils-r1_python_install_all # no-op, but prevents QA warning
- doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
-}