summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-26 12:00:09 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-26 12:35:55 +0200
commit7696763133e170783bed2c359a146830945beb74 (patch)
treef008ce1c94564b8374173aaa3d41d3bb701fe8ca /dev-ruby/hoe
parentgui-libs/gtk: Fix default window sizes in X11 (diff)
downloadgentoo-7696763133e170783bed2c359a146830945beb74.tar.gz
gentoo-7696763133e170783bed2c359a146830945beb74.tar.bz2
gentoo-7696763133e170783bed2c359a146830945beb74.zip
dev-ruby/hoe: add 3.23.1
Closes: https://bugs.gentoo.org/835321 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/hoe')
-rw-r--r--dev-ruby/hoe/Manifest1
-rw-r--r--dev-ruby/hoe/hoe-3.23.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/hoe/Manifest b/dev-ruby/hoe/Manifest
index ef657aca310e..64c8a7b50ba5 100644
--- a/dev-ruby/hoe/Manifest
+++ b/dev-ruby/hoe/Manifest
@@ -1 +1,2 @@
DIST hoe-3.21.0.gem 193024 BLAKE2B 2ff65edc6e0aebc93ebc8f3e628261ac3fabec4034b8e7b1bb3c38ab45c8b4641267a8c46c851ad69425c08782553c628574ae0a1417257cf64ba05a86de08f3 SHA512 39da93520bdb4efcbc58af58562ff8abbdecf45f92071ddb31f68ac799eb6f704431cea3d699aa039ba3a5217dc9b0f2d87f8b553d62860c34cb63803b625754
+DIST hoe-3.23.1.gem 194048 BLAKE2B 907c2f2b62dd362f8c472f21d3fd998bd178de2a15fb9875ef36c61dcbf6b170253037d64f70b04b45a5f7e7dcf9e084122a85f694c6396767d541dccd5693f5 SHA512 c2199f93fe806a9639b319d01ae7bb6999ac203aa8bbabaf22b4c0c5b97f69dbd4e876bdfaaa0b0e8cda68dbd25dfa0e5aa91a599613237fc22de0e857c68c37
diff --git a/dev-ruby/hoe/hoe-3.23.1.ebuild b/dev-ruby/hoe/hoe-3.23.1.ebuild
new file mode 100644
index 000000000000..61df434d6406
--- /dev/null
+++ b/dev-ruby/hoe/hoe-3.23.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation"
+HOMEPAGE="https://www.zenspider.com/projects/hoe.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.9:5 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7 <dev-ruby/rake-15.0"
+
+all_ruby_prepare() {
+ # Skip isolation
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+
+ # Skip test depending on specifics of gem command name
+ sed -i -e '/test_nosudo/,/^ end/ s:^:#:' test/test_hoe.rb || die
+
+ # Avoid test with random sort order
+ sed -i -e '/test_possibly_better/askip "ordering issues"' test/test_hoe.rb || die
+
+ # Avoid test that depends on specifics of merged packages
+ sed -i -e '/test_make_rdoc_cmd/askip "dependent on merged packages"' test/test_hoe_publish.rb || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ rdoc --title "seattlerb's hoe-${PV} Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
+ rm -f doc/js/*.gz || die
+ fi
+}
+
+each_ruby_test() {
+ A="" each_fakegem_test
+}