summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-23 13:26:10 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-23 13:28:12 +0100
commiteaf433a7edd21e6127acff710680c34c4692ef30 (patch)
tree0c03eb4dd10f5df285d607fac68537ab459ec9e4 /dev-ros/image_rotate
parentdev-ros/image_rotate: remove old (diff)
downloadgentoo-eaf433a7edd21e6127acff710680c34c4692ef30.tar.gz
gentoo-eaf433a7edd21e6127acff710680c34c4692ef30.tar.bz2
gentoo-eaf433a7edd21e6127acff710680c34c4692ef30.zip
dev-ros/image_rotate: Backport upstream patch to build with gcc6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/image_rotate')
-rw-r--r--dev-ros/image_rotate/files/gcc6.patch34
-rw-r--r--dev-ros/image_rotate/image_rotate-1.12.19.ebuild3
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-ros/image_rotate/files/gcc6.patch b/dev-ros/image_rotate/files/gcc6.patch
new file mode 100644
index 000000000000..e0737b47cbc7
--- /dev/null
+++ b/dev-ros/image_rotate/files/gcc6.patch
@@ -0,0 +1,34 @@
+commit 6c2d65452bd5fe62723988a1a570789921900d59
+Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date: Fri Sep 30 15:39:47 2016 +0200
+
+ address gcc6 build error
+
+ With gcc6, compiling fails with `stdlib.h: No such file or directory`,
+ as including '-isystem /usr/include' breaks with gcc6, cf.,
+ https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
+
+ This commit addresses this issue for this package in the same way
+ it was addressed in various other ROS packages. A list of related
+ commits and pull requests is at:
+
+ https://github.com/ros/rosdistro/issues/12783
+
+ Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+
+diff --git a/image_rotate/CMakeLists.txt b/image_rotate/CMakeLists.txt
+index 04ba03b..75d8e77 100644
+--- a/image_rotate/CMakeLists.txt
++++ b/image_rotate/CMakeLists.txt
+@@ -12,10 +12,7 @@ find_package(OpenCV REQUIRED core imgproc)
+ find_package(Eigen REQUIRED)
+
+ # add the executable
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS}
+- ${EIGEN_INCLUDE_DIRS}
+- ${OpenCV_INCLUDE_DIRS}
+-)
++include_directories(${catkin_INCLUDE_DIRS} ${EIGEN_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
+
+ add_library(${PROJECT_NAME} SHARED src/nodelet/image_rotate_nodelet.cpp)
+ target_link_libraries(${PROJECT_NAME} ${catkin_LIBRARIES} ${OpenCV_LIBRARIES})
diff --git a/dev-ros/image_rotate/image_rotate-1.12.19.ebuild b/dev-ros/image_rotate/image_rotate-1.12.19.ebuild
index 67b5cf58a8fc..0a83d54e705c 100644
--- a/dev-ros/image_rotate/image_rotate-1.12.19.ebuild
+++ b/dev-ros/image_rotate/image_rotate-1.12.19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -26,3 +26,4 @@ RDEPEND="
dev-ros/tf2_geometry_msgs
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )