summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-24 05:23:01 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-24 05:56:40 -0400
commit4659ad79d9daa6d01cb2578188cc062ae258588c (patch)
tree19c9292f29aae2c4a0bd26d0cb2add2a6a294437 /dev-qt/qtscxml
parentdev-qt/qtquicktimeline: add 6.8.0_rc (diff)
downloadgentoo-4659ad79d9daa6d01cb2578188cc062ae258588c.tar.gz
gentoo-4659ad79d9daa6d01cb2578188cc062ae258588c.tar.bz2
gentoo-4659ad79d9daa6d01cb2578188cc062ae258588c.zip
dev-qt/qtscxml: add 6.8.0_rc
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtscxml')
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/qtscxml-6.8.0_rc.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
index ecd597d67955..2932bb3fd583 100644
--- a/dev-qt/qtscxml/Manifest
+++ b/dev-qt/qtscxml/Manifest
@@ -1,2 +1,3 @@
DIST qtscxml-everywhere-opensource-src-5.15.14.tar.xz 429224 BLAKE2B 67936258bfb67bddf5b711bc97bebb123f56d8f7dca9b46424a33d1205b0a3a6dfc89ae7bc429ffedb928d4f1b88c62abdabee301c09a0e3b0bf65128f174d67 SHA512 1490824b0108300b1924f404431e3871ce067def15993aed9af768c871b3d0eae4cd0b8f467671d3ebcada98d5e11dfe86e250467b7dbf9708ce9f37766861d5
DIST qtscxml-everywhere-src-6.7.2.tar.xz 1168452 BLAKE2B 7cb06fd09758aaea28ccada62aa51b427c265416afa3f152601cadd1c9586050e87d36f8cf9679ca3ef83777bfec1119d861bd9491a176460d58beb5376e4ce4 SHA512 4eba366c2c10593cfc0fdeeff92aa9951b838837cacf113bf849b5da68da4d41d550490bc4be28620f766ab412ca4066c71ee7a1ff18651dd08267b01df6c2fe
+DIST qtscxml-everywhere-src-6.8.0-rc.tar.xz 556928 BLAKE2B 64f8d88845dcc240a2a833f1220e72cccec44d8fafea8ed983b8819aa4b2d82b661ed3ba8823d13aa1adf606d64848bef28340561fca709453bca9ebac4d083d SHA512 5c91d68e673ea50c4a7cc0d1fc5a1eb69e43bacdf8eee337206c10fbd8c21f2375a315bd2c38544313f2c012b85c21fbc596503c79a12572ddb9513a11aaedb9
diff --git a/dev-qt/qtscxml/qtscxml-6.8.0_rc.ebuild b/dev-qt/qtscxml/qtscxml-6.8.0_rc.ebuild
new file mode 100644
index 000000000000..0f087eb496fc
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.8.0_rc.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, considering this flaky)
+ tst_qstatemachine
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}