summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-08 06:06:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-08 06:06:38 +0200
commitf52a24017053437ee589d851942946283a4c9310 (patch)
tree658b715fed3b3f454d55a651beb84f30f8d7a310 /dev-python
parentdev-python/argcomplete: Remove old (diff)
downloadgentoo-f52a24017053437ee589d851942946283a4c9310.tar.gz
gentoo-f52a24017053437ee589d851942946283a4c9310.tar.bz2
gentoo-f52a24017053437ee589d851942946283a4c9310.zip
dev-python/pygobject: Replace our py3.12 sed with upstream fix
Replace our cheap test hack using `.*` regex with upstream patch that conditionalizes the expected value per Python version. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygobject/files/pygobject-3.44.1-py312.patch48
-rw-r--r--dev-python/pygobject/pygobject-3.44.1.ebuild13
2 files changed, 53 insertions, 8 deletions
diff --git a/dev-python/pygobject/files/pygobject-3.44.1-py312.patch b/dev-python/pygobject/files/pygobject-3.44.1-py312.patch
new file mode 100644
index 000000000000..331e3bc0a3f8
--- /dev/null
+++ b/dev-python/pygobject/files/pygobject-3.44.1-py312.patch
@@ -0,0 +1,48 @@
+From fe6aedd8eebd92844b873f72e99dc4023316c6f3 Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Wed, 7 Jun 2023 22:27:55 +0200
+Subject: [PATCH] tests: fix test_gvalue_flat_array_in_item_marshal_failure for
+ Python 3.12
+
+See https://gitlab.gnome.org/GNOME/pygobject/-/issues/582
+
+_PyGI_ERROR_PREFIX() no longer works with 3.12 since we only get normalized
+exceptions in there and can't add a prefix like "Item X: " to the message.
+
+Until we figure out how to add this back for 3.12, align the tests with the
+new behaviour (the new exception notes API would be an option, see the
+linked issue)
+---
+ tests/test_gi.py | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/tests/test_gi.py b/tests/test_gi.py
+index 25a3b659..261d8b2b 100644
+--- a/tests/test_gi.py
++++ b/tests/test_gi.py
+@@ -1573,9 +1573,12 @@ class TestGValue(unittest.TestCase):
+ self.assertRaises(OverflowError, GIMarshallingTests.gvalue_flat_array,
+ [GLib.MININT - 1, "42", True])
+
++ # FIXME: https://gitlab.gnome.org/GNOME/pygobject/-/issues/582#note_1764164
++ exc_prefix = "Item 0: " if sys.version_info[:2] < (3, 12) else ""
++
+ with pytest.raises(
+ OverflowError,
+- match='Item 0: %d not in range %d to %d' % (
++ match=exc_prefix + '%d not in range %d to %d' % (
+ GLib.MAXINT + 1, GLib.MININT, GLib.MAXINT)):
+ GIMarshallingTests.gvalue_flat_array([GLib.MAXINT + 1, "42", True])
+
+@@ -1583,7 +1586,7 @@ class TestGValue(unittest.TestCase):
+
+ with pytest.raises(
+ OverflowError,
+- match='Item 0: %d not in range %d to %d' % (
++ match=exc_prefix + '%d not in range %d to %d' % (
+ GLib.MAXUINT64 * 2, min_, max_)):
+ GIMarshallingTests.gvalue_flat_array([GLib.MAXUINT64 * 2, "42", True])
+
+--
+GitLab
+
diff --git a/dev-python/pygobject/pygobject-3.44.1.ebuild b/dev-python/pygobject/pygobject-3.44.1.ebuild
index 231063a2d18f..713c63dc4584 100644
--- a/dev-python/pygobject/pygobject-3.44.1.ebuild
+++ b/dev-python/pygobject/pygobject-3.44.1.ebuild
@@ -44,14 +44,11 @@ BDEPEND="
virtual/pkgconfig
"
-src_prepare() {
- # workaround minor py3.12 test failure
- # (I wish we could just use EPYTEST_DESELECT here, sigh)
- # https://gitlab.gnome.org/GNOME/pygobject/-/issues/582
- sed -i -e 's@Item 0: @.*@' tests/test_gi.py || die
-
- distutils-r1_src_prepare
-}
+PATCHES=(
+ # fix test failure on py3.12
+ # https://gitlab.gnome.org/GNOME/pygobject/-/commit/fe6aedd8eebd92844b873f72e99dc4023316c6f3
+ "${FILESDIR}/${P}-py312.patch"
+)
python_configure() {
local emesonargs=(