summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-02 21:31:37 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-02 21:31:37 +0100
commit0a503d866fd9afdcd81f13b4db73e3d8f2c9cec8 (patch)
tree061a8b5cc7c584e05492d202d0cad88456f322bb /dev-python
parentdev-util/android-tools: Apply musl-1.2.4 largefile workaround (diff)
downloadgentoo-0a503d866fd9afdcd81f13b4db73e3d8f2c9cec8.tar.gz
gentoo-0a503d866fd9afdcd81f13b4db73e3d8f2c9cec8.tar.bz2
gentoo-0a503d866fd9afdcd81f13b4db73e3d8f2c9cec8.zip
dev-python/pymdown-extensions: Skip failing test properly
Closes: https://bugs.gentoo.org/926017 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pymdown-extensions/pymdown-extensions-10.7.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-python/pymdown-extensions/pymdown-extensions-10.7.ebuild b/dev-python/pymdown-extensions/pymdown-extensions-10.7.ebuild
index b625aeccdfcc..69a0a4e1cc22 100644
--- a/dev-python/pymdown-extensions/pymdown-extensions-10.7.ebuild
+++ b/dev-python/pymdown-extensions/pymdown-extensions-10.7.ebuild
@@ -31,16 +31,17 @@ BDEPEND="
distutils_enable_tests pytest
-python_test() {
- local EPYTEST_DESELECT=()
- case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- 'tests/test_syntax.py::test_extensions[compare54]'
- )
- ;;
- esac
+src_prepare() {
+ # broken on pypy3; unfortunately, the parametrization is based
+ # on indexes and these are pretty random, so we need to remove it
+ # entirely
+ # TODO: restore it when pypy with a fix is in Gentoo
+ # https://github.com/pypy/pypy/issues/4920
+ rm "tests/extensions/superfences/superfences (normal).txt" || die
+ distutils-r1_src_prepare
+}
+python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}