summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-26 18:58:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-26 18:58:04 +0300
commitd173559e256d1095a5e4ac00acb349889b0b7656 (patch)
tree3c5fdd65b3195ea7b47ed49ca4ecf7a8e00985c4 /dev-python/xmlschema
parentdev-python/peewee: add 3.15.2 (diff)
downloadgentoo-d173559e256d1095a5e4ac00acb349889b0b7656.tar.gz
gentoo-d173559e256d1095a5e4ac00acb349889b0b7656.tar.bz2
gentoo-d173559e256d1095a5e4ac00acb349889b0b7656.zip
dev-python/xmlschema: add 2.0.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-2.0.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index 0c468d4aa883..f64a294c138f 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1,2 +1,3 @@
DIST xmlschema-2.0.1.tar.gz 475999 BLAKE2B 646f839ec8c1e3e7a18250e5e98a2d2503974b331a296c428eeceb5400af792c432851bf4cc7b8a15bfa815a9316f3a243535412344fd968ede7fbbee352bce5 SHA512 2087c3a4dc8517b3a05e852f213c611c6040c9bf41a392b26467a9d4a27140a2ce577a13cb1d0f4074f1d3d8bc33d6e115386cb1d675a6b6ee5ee29c01b20173
DIST xmlschema-2.0.2.tar.gz 476241 BLAKE2B 56d1708a2139591d4efaa93a448485cef28f6a4dfd602f6919a4d7afaf249c5ec8d4500062a5f959d2d4f7a28819d8e45724830b09e1e66298192af0f8ddd32f SHA512 3ec7a6a8337e1c342e4f4db02fac51a5b31a95f21b4630d8750014c418ecfd12fecd271309bd18235288f373f3e01511998af907adcd444720b6f14d13762123
+DIST xmlschema-2.0.3.tar.gz 479014 BLAKE2B 19b5e3892a59e780c23c4b9789901a55509b63d3dd3466d473a47aa43eec8894ad2f99dbae7fa2063a53430d99db1455dd2e370fc0e1932750bf6aecc6657b8e SHA512 ab805229d28d53bbc265a4393ca286d0df81803c53ec16b52879ce3edcdc5e7576602088b5fe977e13dcfb5039af652ef96be5a3e9d23592fee104da5a486516
diff --git a/dev-python/xmlschema/xmlschema-2.0.3.ebuild b/dev-python/xmlschema/xmlschema-2.0.3.ebuild
new file mode 100644
index 000000000000..829df9709686
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-2.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="
+ https://github.com/sissaschool/xmlschema/
+ https://pypi.org/project/xmlschema/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/elementpath-4[${PYTHON_USEDEP}]
+ >=dev-python/elementpath-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v || die "Tests fail with ${EPYTHON}"
+}