summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-14 06:09:27 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-14 07:11:07 +0100
commitd8f21a1c14be6c498a484ff5342932755f9c2a98 (patch)
treec8e7f5b548a956c897bbb94c979a33471b62ee7d /dev-python/trio-websocket
parentdev-python/google-api-python-client: Bump to 2.81.0 (diff)
downloadgentoo-d8f21a1c14be6c498a484ff5342932755f9c2a98.tar.gz
gentoo-d8f21a1c14be6c498a484ff5342932755f9c2a98.tar.bz2
gentoo-d8f21a1c14be6c498a484ff5342932755f9c2a98.zip
dev-python/trio-websocket: Bump to 0.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trio-websocket')
-rw-r--r--dev-python/trio-websocket/Manifest1
-rw-r--r--dev-python/trio-websocket/trio-websocket-0.10.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/trio-websocket/Manifest b/dev-python/trio-websocket/Manifest
index 1f25a757c7ef..3b52207d94d9 100644
--- a/dev-python/trio-websocket/Manifest
+++ b/dev-python/trio-websocket/Manifest
@@ -1 +1,2 @@
+DIST trio-websocket-0.10.0.gh.tar.gz 43808 BLAKE2B fd89ab74c3844a14940ce07a0abc07a0392607b492fa4b6e1d81ba3aa2c37338706975cb800332751c9ea70e934c4169fdcd29dd047019096726164a2130daa9 SHA512 04d775a7c1a232b470a7f415b57debce4bd1c3732934a94d65e3c9f3bb45c5ffea7464557100e2e9f68a2aa6a7812bd686220de046f399a0d0242309d2d9be59
DIST trio-websocket-0.9.2.gh.tar.gz 43146 BLAKE2B f5463d20253c3686a0d0fe4cb38ffec235c4378c14ed2952b3518486602b06bb961291d098542a52dee7e25506713df382e303cd2dc7fa579041124d66c8ecb8 SHA512 0f25a7d234a6d9f7c0c0bdbbd2836e6baee02b4ff2daab8354f8fd483a10de65fe357a273675a172227b1b0e9f7cf6cf27ddfdf9426d1b330122a8b2ef957435
diff --git a/dev-python/trio-websocket/trio-websocket-0.10.0.ebuild b/dev-python/trio-websocket/trio-websocket-0.10.0.ebuild
new file mode 100644
index 000000000000..b95a0f2797fc
--- /dev/null
+++ b/dev-python/trio-websocket/trio-websocket-0.10.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSocket client and server implementation for Python Trio"
+HOMEPAGE="
+ https://github.com/HyperionGray/trio-websocket/
+ https://pypi.org/project/trio-websocket/
+"
+SRC_URI="
+ https://github.com/HyperionGray/trio-websocket/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.11[${PYTHON_USEDEP}]
+ >=dev-python/wsproto-0.14[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-trio-0.5.0[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p trio
+}