summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-20 08:11:07 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-20 09:16:57 +0200
commit8e26749dbdd26fc216f4ab715056870c9018f07c (patch)
tree5f50030643100bc1ab80c02900d51e4df2f6b4b5 /dev-python/translate-toolkit
parentdev-python/jupyter_client: Bump to 7.0.1 (diff)
downloadgentoo-8e26749dbdd26fc216f4ab715056870c9018f07c.tar.gz
gentoo-8e26749dbdd26fc216f4ab715056870c9018f07c.tar.bz2
gentoo-8e26749dbdd26fc216f4ab715056870c9018f07c.zip
dev-python/translate-toolkit: Skip tests requiring fluent
Closes: https://bugs.gentoo.org/809146 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.4.0.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.4.0.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.4.0.ebuild
index b816d199c9f7..cdc540e11264 100644
--- a/dev-python/translate-toolkit/translate-toolkit-3.4.0.ebuild
+++ b/dev-python/translate-toolkit/translate-toolkit-3.4.0.ebuild
@@ -50,28 +50,32 @@ PATCHES=(
)
python_test() {
- local deselect=(
+ local EPYTEST_DESELECT=(
# Fails with network-sandbox (and even with it off but w/ softer fail)
- --deselect 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
- --deselect 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ translate/storage/test_fluent.py
)
if ! use ini; then
- deselect+=(
- --ignore translate/convert/test_ini2po.py
- --ignore translate/convert/test_po2ini.py
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
)
fi
if ! use subtitles; then
- deselect+=(
- --ignore translate/storage/test_subtitles.py
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
)
fi
# translate/storage/test_mo.py needs 'pocompile'
distutils_install_for_testing
- epytest "${deselect[@]}"
+ epytest
}
python_install_all() {