summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-14 17:37:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-14 17:55:54 +0100
commitf05d47330e5f0712952e3e1105909695e060f8aa (patch)
tree1049257605974118aa2dfbf7c0a27713cb95248a /dev-python/tavern
parentdev-python/testtools: Bump to 2.6.0 (diff)
downloadgentoo-f05d47330e5f0712952e3e1105909695e060f8aa.tar.gz
gentoo-f05d47330e5f0712952e3e1105909695e060f8aa.tar.bz2
gentoo-f05d47330e5f0712952e3e1105909695e060f8aa.zip
dev-python/tavern: Bump to 2.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tavern')
-rw-r--r--dev-python/tavern/Manifest1
-rw-r--r--dev-python/tavern/tavern-2.0.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/tavern/Manifest b/dev-python/tavern/Manifest
index 7308def6fa71..98c2590decf2 100644
--- a/dev-python/tavern/Manifest
+++ b/dev-python/tavern/Manifest
@@ -1 +1,2 @@
DIST tavern-2.0.1.gh.tar.gz 208510 BLAKE2B a1b6f19d188437758690eced663556e9e3a5cfc8cedf4e04baba0478efd9507faa5dce2c6f308b2ce6e806617a5e75a8a1b2e60d9afe804b2294ca772ffbc7e9 SHA512 72025db6efa7d41f7dfe80ffc83033e12941ac3a9c4b71170647e571f6ce5022c84c0976d7d50fdfe38da06a4b516e334eed2334e016cfb013613fcc05eeaa9e
+DIST tavern-2.0.6.gh.tar.gz 207404 BLAKE2B 6dc5a01bac0ffce55e3459dcaf4bab60852c4d06c29e86fb6006ad7279cc7114d8e18dbdd6ce07edb70beebc77c13d4c1a34498232dcdafa9827085c7be63361 SHA512 d660a773fae85d40ea461a3529fd233f392f2b523501984f7f228b0b45439309a8386559477154db5bc90c0b2f3b52f27a658f30dd9ed83a945dcf8f7faf74c7
diff --git a/dev-python/tavern/tavern-2.0.6.ebuild b/dev-python/tavern/tavern-2.0.6.ebuild
new file mode 100644
index 000000000000..d056f7b90089
--- /dev/null
+++ b/dev-python/tavern/tavern-2.0.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool, library, and Pytest plugin for testing RESTful APIs"
+HOMEPAGE="
+ https://github.com/taverntesting/tavern/
+ https://pypi.org/project/tavern/
+"
+SRC_URI="
+ https://github.com/taverntesting/tavern/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/paho-mqtt[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/pykwalify[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/python-box[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/Faker[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # strip unnecessary pins, upstream doesn't update them a lot
+ sed -i -E -e 's:,?<=?[0-9.]+::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -p tavern
+}