summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-18 17:39:04 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-18 17:40:05 +0200
commitde3a67e59307712134c89e074d539149dda15996 (patch)
treeeadef9a201308aed439e0b438c9f8dc5ac1d788b /dev-python/sh
parentdev-python/setuptools: Remove old (diff)
downloadgentoo-de3a67e59307712134c89e074d539149dda15996.tar.gz
gentoo-de3a67e59307712134c89e074d539149dda15996.tar.bz2
gentoo-de3a67e59307712134c89e074d539149dda15996.zip
dev-python/sh: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sh')
-rw-r--r--dev-python/sh/Manifest1
-rw-r--r--dev-python/sh/files/sh-1.12.14-tests.patch43
-rw-r--r--dev-python/sh/sh-1.12.14.ebuild29
3 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/sh/Manifest b/dev-python/sh/Manifest
index 9b5e5a0e3f3b..7a8fd5dce64d 100644
--- a/dev-python/sh/Manifest
+++ b/dev-python/sh/Manifest
@@ -1,2 +1 @@
-DIST sh-1.12.14.tar.gz 56861 BLAKE2B dcab86c518fdfdf763053f05a6701fbd0faa76e05d710d6ef709dca89b7527157385ecde355f5f358ba08f7da8e551712732ef43f3074f5568fc7092ed12f014 SHA512 5f2daa2666cf8efe90ba550c8ea5875f2a8812d787597c9d9b933f58feccd192e1ec0ab5695b756bdbfbf9748d106c2045be20838e680b31dac3f778970b5786
DIST sh-1.14.0.tar.gz 63313 BLAKE2B 9975944455077729d172a34dcf7847930f9bb943d5345729a9c09afeb411de72b59cd5e4f1192406ba8430a26439acd2ee4d477b10f31b5e55be936c711f70a9 SHA512 816c0562f4f779ba79b5206d151893cd5043898d1b74ee109c0ea67f862a097ab9c7509e4a20459fc623f14fa3fb1a9e2a2ccec8257a68fcba14414779a20128
diff --git a/dev-python/sh/files/sh-1.12.14-tests.patch b/dev-python/sh/files/sh-1.12.14-tests.patch
deleted file mode 100644
index bc3d1b59fef6..000000000000
--- a/dev-python/sh/files/sh-1.12.14-tests.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff --git a/test.py b/test.py
-index 68ef40c..640e5b5 100644
---- a/test.py
-+++ b/test.py
-@@ -515,6 +515,13 @@ def test_environment(self):
- "VERSIONER_PYTHON_VERSION",
- ]
-
-+ # On python-3.7+, the changes for no encoding inject LC_CTYPE into subprocesses
-+ py37_extra_envvars = [
-+ "LC_CTYPE",
-+ ]
-+
-+ prune_envvars = osx_cruft + py37_extra_envvars
-+
- # first we test that the environment exists in our child process as
- # we've set it
- py = create_tmp_test("""
-@@ -525,7 +532,7 @@ def test_environment(self):
- try: del os.environ[key]
- except: pass
- print(os.environ["HERP"] + " " + str(len(os.environ)))
--""" % osx_cruft)
-+""" % prune_envvars)
- out = python(py.name, _env=env).strip()
- self.assertEqual(out, "DERP 1")
-
-@@ -533,12 +540,12 @@ def test_environment(self):
- import os, sys
- sys.path.insert(0, os.getcwd())
- import sh
--osx_cruft = %s
--for key in osx_cruft:
-+prune_envvars = %s
-+for key in prune_envvars:
- try: del os.environ[key]
- except: pass
- print(sh.HERP + " " + str(len(os.environ)))
--""" % osx_cruft)
-+""" % prune_envvars)
- out = python(py.name, _env=env, _cwd=THIS_DIR).strip()
- self.assertEqual(out, "DERP 1")
-
diff --git a/dev-python/sh/sh-1.12.14.ebuild b/dev-python/sh/sh-1.12.14.ebuild
deleted file mode 100644
index 57ff7f3454da..000000000000
--- a/dev-python/sh/sh-1.12.14.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python subprocess interface"
-HOMEPAGE="https://github.com/amoffat/sh"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/sh-1.12.14-skip-unreliable-test.patch"
-
- # https://github.com/amoffat/sh/pull/468
- "${FILESDIR}/sh-1.12.14-tests.patch"
-)
-
-python_test() {
- "${EPYTHON}" test.py || die "Tests fail with ${EPYTHON}"
-}