summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-10 09:08:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-10 09:24:10 +0200
commit10cb0e2bbda24e817de92727fb21614ae89abe3c (patch)
tree465ee8b7614f9b50a85d8c17d3fd05de7c24b942 /dev-python/serpent
parentdev-python/findimports: Bump to 2.0.0 (diff)
downloadgentoo-10cb0e2bbda24e817de92727fb21614ae89abe3c.tar.gz
gentoo-10cb0e2bbda24e817de92727fb21614ae89abe3c.tar.bz2
gentoo-10cb0e2bbda24e817de92727fb21614ae89abe3c.zip
dev-python/serpent: Bump to 1.40
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/serpent')
-rw-r--r--dev-python/serpent/Manifest1
-rw-r--r--dev-python/serpent/serpent-1.40.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/serpent/Manifest b/dev-python/serpent/Manifest
index 78fcd8bb6c83..200330039b37 100644
--- a/dev-python/serpent/Manifest
+++ b/dev-python/serpent/Manifest
@@ -1 +1,2 @@
DIST serpent-1.30.2.tar.gz 24182 BLAKE2B 9a7f492dbd06331e7e0b7c264fff2c0b184258565d43773eb75dcdd53b8d74df60995439060af0514904043528757201b8fcea4c9bfa56237efe77849abc582e SHA512 1cbc490deae3fb81c59abf74a98437e8c31f1ad88ce31a96c7ae48f344701dfcd67e973d2829cf793c405c6c1930cb7f15dec129c0a0e1b475286dd4f219ff99
+DIST serpent-1.40.tar.gz 24140 BLAKE2B 8a790e3f0973e99840cbea6ad354012cde0b7c6ee09c50f31d56110e12cf848543a30a38900e821419c9a0aaeb2b55fe0161dbc9c233f236a21dc553cefce9e6 SHA512 9f8edebcd6e37de7442a00157f64b1dec6742cd198f45ab475be7f38aff4e090345739f7500181f0b0a4dbdc9241b2f11bca5ada7a89aa577d94646269d7ab28
diff --git a/dev-python/serpent/serpent-1.40.ebuild b/dev-python/serpent/serpent-1.40.ebuild
new file mode 100644
index 000000000000..4e40de17c426
--- /dev/null
+++ b/dev-python/serpent/serpent-1.40.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A simple serialization library based on ast.literal_eval"
+HOMEPAGE="https://pypi.org/project/serpent/ https://github.com/irmen/Serpent"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py