summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-23 18:50:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-23 19:08:17 +0300
commit53b0734dbbcf2ab2e47f90417aeaa81445bd1f4c (patch)
tree2ace1ee5f546eef6a66ced38c0fe95a537b10459 /dev-python/python3-openid
parentprofiles/package.mask: removed dev-java/{piccolo2d,trident} (diff)
downloadgentoo-53b0734dbbcf2ab2e47f90417aeaa81445bd1f4c.tar.gz
gentoo-53b0734dbbcf2ab2e47f90417aeaa81445bd1f4c.tar.bz2
gentoo-53b0734dbbcf2ab2e47f90417aeaa81445bd1f4c.zip
dev-python/python3-openid: enable py3.10, enable tests
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python3-openid')
-rw-r--r--dev-python/python3-openid/python3-openid-3.2.0.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/dev-python/python3-openid/python3-openid-3.2.0.ebuild b/dev-python/python3-openid/python3-openid-3.2.0.ebuild
index c1f5bca4f6c8..6066e6b63193 100644
--- a/dev-python/python3-openid/python3-openid-3.2.0.ebuild
+++ b/dev-python/python3-openid/python3-openid-3.2.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -14,9 +14,19 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/defusedxml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND}
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/psycopg[${PYTHON_USEDEP}]
+ )
+"
DOCS=( NEWS.md README.md )
+
+python_test() {
+ "${EPYTHON}" -m unittest -v openid.test.test_suite || die "Tests failed with ${EPYTHON}"
+}