summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-12 16:06:24 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-12 17:46:57 -0500
commitcef6e99c68a6bd2ac33d5a208275692b52a1446a (patch)
tree36a4ac1e728defacbfb49313c274d0880fdf9554 /dev-python/python-blazarclient
parentdev-python/aodhclient: 1.2.0 bump (diff)
downloadgentoo-cef6e99c68a6bd2ac33d5a208275692b52a1446a.tar.gz
gentoo-cef6e99c68a6bd2ac33d5a208275692b52a1446a.tar.bz2
gentoo-cef6e99c68a6bd2ac33d5a208275692b52a1446a.zip
dev-python/python-blazarclient: 2.1.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-blazarclient')
-rw-r--r--dev-python/python-blazarclient/Manifest1
-rw-r--r--dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-blazarclient/Manifest b/dev-python/python-blazarclient/Manifest
index c84d2464ed56..90714924616b 100644
--- a/dev-python/python-blazarclient/Manifest
+++ b/dev-python/python-blazarclient/Manifest
@@ -1 +1,2 @@
DIST python-blazarclient-2.0.0.tar.gz 32078 BLAKE2B a8f7359485889d41c8e6a36f90f6279a366210d29e3080353fe32e6ee6929784c954c86f0e645d4cefe104132b557648ce27a59873a8248c68d02a0c954490c3 SHA512 af57b7a9d914ed216fe53f6e102ade25654fcf9cc0d4a422c912b2129f5905f47272ea959fab38f0ac23678e719c8b5807fa5e852b22f5f7418c72a17d25412a
+DIST python-blazarclient-2.1.0.tar.gz 32950 BLAKE2B cdad6f6e60e95ba97fff6a3d54e642679e2ba203d1aadcadb8190c9fda38dab27808ffbddcfa41852dc72504e9009ec62863991f832d086d70e22bf9652151b5 SHA512 a5d2749969d354ff96b4f223d49f69333a874f167e62663edf4209879b3783d1272dc591157b5a8d1b25206e7c796aa4e0d5966de74aac4429c2ebd9670d1987
diff --git a/dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild b/dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild
new file mode 100644
index 000000000000..16b10cdbd22c
--- /dev/null
+++ b/dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client for the OpenStack Blazar API"
+HOMEPAGE="https://github.com/openstack/python-blazarclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ !~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+"