summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-22 15:30:00 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-22 15:30:49 +0100
commit3dec1c16564617039ea8a6e345eeb419fbd95d0b (patch)
treee99e9df646ef32209396d259fa956c8e0cc50601 /dev-python/pytest-skip-markers
parentdev-python/pycollada: Remove old (diff)
downloadgentoo-3dec1c16564617039ea8a6e345eeb419fbd95d0b.tar.gz
gentoo-3dec1c16564617039ea8a6e345eeb419fbd95d0b.tar.bz2
gentoo-3dec1c16564617039ea8a6e345eeb419fbd95d0b.zip
dev-python/pytest-skip-markers: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-skip-markers')
-rw-r--r--dev-python/pytest-skip-markers/Manifest1
-rw-r--r--dev-python/pytest-skip-markers/pytest-skip-markers-1.4.1.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/pytest-skip-markers/Manifest b/dev-python/pytest-skip-markers/Manifest
index fff547d386cc..1e1d4e98594c 100644
--- a/dev-python/pytest-skip-markers/Manifest
+++ b/dev-python/pytest-skip-markers/Manifest
@@ -1,2 +1 @@
-DIST pytest-skip-markers-1.4.1.gh.tar.gz 71828 BLAKE2B 2abd097c529a6db51f36de6f5ac705da981e87196da4ccf99895b24277e9d4d717c80ebcf6b8d72959b7f76a10f23c2be11608c390845cca215472d2d4e99326 SHA512 c54cd2cafbe29648cfeccc2dc25b245e2e1a226ca6eb9e1c77e6aeb705e06c4b67854dd81673955fb77e16d1128c247d92d38d19dbedbdf01924a95c01721f3c
DIST pytest-skip-markers-1.5.0.gh.tar.gz 73142 BLAKE2B 26575a1a7880714b3af4fd7b02b5c5d56b99e0ad0947012823e6c917afe7ca134e930f2bf75b3504fe3fd1516d39e82acd7dae799255b30c370ae085d0cff402 SHA512 217fae64013a0d0f4b91d33a22576df9dece1bdda28beda0919e3638ed6cddcf24715971fb1da8e8c62df50510c969ce24716044d6aa05f8a0b4891082e83584
diff --git a/dev-python/pytest-skip-markers/pytest-skip-markers-1.4.1.ebuild b/dev-python/pytest-skip-markers/pytest-skip-markers-1.4.1.ebuild
deleted file mode 100644
index 84ed222db58a..000000000000
--- a/dev-python/pytest-skip-markers/pytest-skip-markers-1.4.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Pytest plugin which implements a few useful skip markers"
-HOMEPAGE="
- https://pytest-skip-markers.readthedocs.io/en/latest/
- https://github.com/saltstack/pytest-skip-markers
-"
-SRC_URI="
- https://github.com/saltstack/pytest-skip-markers/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/pytest-7.1.0[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/distro[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/pyfakefs[${PYTHON_USEDEP}]
- dev-python/pytest-subtests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytestskipmarkers.plugin,pyfakefs.pytest_plugin
- epytest
-}