summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 06:33:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 07:16:19 +0200
commit84e9ba00f9c4d96393f9a2398fa0e489ca275f7f (patch)
tree8f646c1f431381a66c7cb1cb74055963dc8f1f5c /dev-python/pytest-env
parentdev-python/shellingham: Bump to 1.5.4 (diff)
downloadgentoo-84e9ba00f9c4d96393f9a2398fa0e489ca275f7f.tar.gz
gentoo-84e9ba00f9c4d96393f9a2398fa0e489ca275f7f.tar.bz2
gentoo-84e9ba00f9c4d96393f9a2398fa0e489ca275f7f.zip
dev-python/pytest-env: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-env')
-rw-r--r--dev-python/pytest-env/Manifest1
-rw-r--r--dev-python/pytest-env/pytest-env-1.1.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-env/Manifest b/dev-python/pytest-env/Manifest
index dd0811bfabb3..320e0b022b84 100644
--- a/dev-python/pytest-env/Manifest
+++ b/dev-python/pytest-env/Manifest
@@ -1 +1,2 @@
DIST pytest_env-1.0.1.tar.gz 7565 BLAKE2B 26aa1c6a5d44bbe40266bbb62ca62c687dd1d85aed821c271f301ff27a97fdc753d2cdf5feba8b223b33b5b05bf39c55c3df0f1f8f7aae77335f2052a65df6c0 SHA512 422aaa78e25fad7b447f06358b772cacf22d5441ae0aaac22863877424f44703c1329813b068d901d4f2fb9df21bb08a5e4082504b76102d02dd15087d527a01
+DIST pytest_env-1.1.0.tar.gz 8640 BLAKE2B 384b438c6a5da2ddeac0be1a601b74eca77abbe5b5100322f9f161f5e68119980370aa1c8f8160ca9db53628209742afabd981678784e2c42a1f527344c39558 SHA512 12fb8d1093f9d9e89a2bb543428086cba04a322a4d443960d3ab33f270a3aa8f98585c334091d90febe3a5f4d4d66111dd5a8a5a7322185af10cae3eae14bfde
diff --git a/dev-python/pytest-env/pytest-env-1.1.0.ebuild b/dev-python/pytest-env/pytest-env-1.1.0.ebuild
new file mode 100644
index 000000000000..407864cef54b
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows you to add environment variables"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-env/
+ https://pypi.org/project/pytest-env/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}