summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-18 13:08:01 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-18 13:49:54 +0100
commitc4abfd878d8080d0247fb5ad1220bfd5868d94d3 (patch)
tree85ccb17b43439a8028c1f303e9a542aae56d9570 /dev-python/pyhamcrest
parentdev-python/tempora: Enable testing on pypy3.11 (diff)
downloadgentoo-c4abfd878d8080d0247fb5ad1220bfd5868d94d3.tar.gz
gentoo-c4abfd878d8080d0247fb5ad1220bfd5868d94d3.tar.bz2
gentoo-c4abfd878d8080d0247fb5ad1220bfd5868d94d3.zip
dev-python/pyhamcrest: Deselect obsolete <dev-python/numpy-2 tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyhamcrest')
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild b/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
index 40ac59715027..ab34cf765e49 100644
--- a/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
+++ b/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
@@ -35,6 +35,17 @@ distutils_enable_tests pytest
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+python_test() {
+ local EPYTEST_DESELECT=(
+ # removed in numpy 2.0, https://github.com/hamcrest/PyHamcrest/pull/248
+ tests/hamcrest_unit_test/number/iscloseto_test.py::IsNumericTest::test_numpy_numeric_type_complex
+ tests/hamcrest_unit_test/number/iscloseto_test.py::IsNumericTest::test_numpy_numeric_type_float
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
python_install_all() {
use examples && dodoc -r examples
distutils-r1_python_install_all