summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-22 20:28:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-22 20:28:20 +0300
commit6e2d503b8abbcb8dec8951d3fe62f9a9adeeed55 (patch)
tree869f902468d1bc63d3988d97febd3bfda454dd3a /dev-python/pyghmi
parentdev-python/cfn-lint: add 0.61.1 (diff)
downloadgentoo-6e2d503b8abbcb8dec8951d3fe62f9a9adeeed55.tar.gz
gentoo-6e2d503b8abbcb8dec8951d3fe62f9a9adeeed55.tar.bz2
gentoo-6e2d503b8abbcb8dec8951d3fe62f9a9adeeed55.zip
dev-python/pyghmi: add 1.5.48
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.48.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 531266d65a7d..24851fd604b5 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1 +1,2 @@
DIST pyghmi-1.5.47.tar.gz 243783 BLAKE2B 4611df2616c7681c10664b645969b40f85a41ea2f16c3bcd4123230e90087903e6d7265b0147d93f994a4af32a77750685230d4e977418ba129a3e2093f8065c SHA512 f4122537488ca05035603f15106646e539c5081ee71ba3fc1f37e8175ffe98dbbc59446fa4683816a4211b90bb9f82adea4c5d42e4ce8b2b301c35f862262394
+DIST pyghmi-1.5.48.tar.gz 243927 BLAKE2B 8395aa3bbba752654c2ad73f76735370f31f9548f91e7e0bbb3e52afd2d67a00b316f7e1e25a49ad16004308a635104fa57a00a6bed63639068de86d96e44316 SHA512 f3ee4d44504b2fa5950817e1957ac23c666af6ba36b0ba65dafa5b42036d12d204accf996c75947ecdb5f9533025b9b0d17b0e96612019d622fee678fd0ff592
diff --git a/dev-python/pyghmi/pyghmi-1.5.48.ebuild b/dev-python/pyghmi/pyghmi-1.5.48.ebuild
new file mode 100644
index 000000000000..1844c945d4be
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.48.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest