summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-11-17 22:34:21 +0200
committerMart Raudsepp <leio@gentoo.org>2019-11-17 22:34:31 +0200
commit947ed4030afc261a1c03390fcd529e8119a1ea8b (patch)
treea5767ab64ff57675438156eba6fffce5cb56cc48 /dev-python/pyatspi
parentdev-libs/gmime: Add RESTRICT="!test? ( test )" (diff)
downloadgentoo-947ed4030afc261a1c03390fcd529e8119a1ea8b.tar.gz
gentoo-947ed4030afc261a1c03390fcd529e8119a1ea8b.tar.bz2
gentoo-947ed4030afc261a1c03390fcd529e8119a1ea8b.zip
dev-python/pyatspi: bump to 2.34.0, other tweaks
Fix lack of python optimization all levels with py3. Update DESCRIPTION. Support python3.7. Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/Manifest1
-rw-r--r--dev-python/pyatspi/pyatspi-2.34.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pyatspi/Manifest b/dev-python/pyatspi/Manifest
index 5c0d1ddce50d..aead3b53bcd0 100644
--- a/dev-python/pyatspi/Manifest
+++ b/dev-python/pyatspi/Manifest
@@ -1,2 +1,3 @@
DIST pyatspi-2.30.0.tar.xz 310672 BLAKE2B 76d51e6ce2f39305bcda8f706b5207738d3a2c0fd7480efb77c4dab8baf8ed6eb71263375ff0c16be0087e47f7f6b5eab99c6fc8992b83bdea6e64c92c381043 SHA512 a7af81bb55dff45d1bceced645f6aeb1adc1fa2a2b61fc39d9e97b6659e474636e5ac1af9923588311e651fee57b5e31a62ea5b2977b341eda43a5a736bf27ed
DIST pyatspi-2.32.1.tar.xz 310896 BLAKE2B acf4a0211015daf5a19a796de9e267637ae77b2f79f0c6af20bfa5eb5a0fa0d4a62cf23524348299daebd515cccb7a4a1c18226e8c04356ea6439840613242a7 SHA512 6cdddc4275770a4f89e66355e18518f5cbf1ceeee1f27298be1fb5bb8b67676eeeb81ce7f4fbb5ad617573f574e5fd5858d363c77a0e5727d637ae7275429b03
+DIST pyatspi-2.34.0.tar.xz 314060 BLAKE2B 1d2c390c6f110a37e9553b1f1aeba75fa0585beabddb2d6db54aa8fddc671b844e7c670c7fdf9696e3833c8f9619dc8a2ecc364019f14703647e7996033c7dd7 SHA512 61b157f067e23b7a964cf8268f556ad059982f448e436ecb25c96915ecb53918c6ab7b29bfb4e7b85e25e6038e27678fbd3d0bfb61d14a038ab5eaeee1f682b4
diff --git a/dev-python/pyatspi/pyatspi-2.34.0.ebuild b/dev-python/pyatspi/pyatspi-2.34.0.ebuild
new file mode 100644
index 000000000000..11642c0a868e
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.34.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Python client bindings for D-Bus AT-SPI"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="" # test
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/atk-2.11.2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-2.34[introspection]
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure --disable-tests
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installing
+
+ docinto examples
+ dodoc examples/*.py
+}