summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-02 14:48:24 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-02 16:52:09 -0800
commit8fe0c6e7e883e0db58f814340b9ddda707744d51 (patch)
treecf45b2d9896a053eb71ff9dddab16f0ca2be60ee /dev-python/parso
parentmedia-libs/libvorbis: security bump (diff)
downloadgentoo-8fe0c6e7e883e0db58f814340b9ddda707744d51.tar.gz
gentoo-8fe0c6e7e883e0db58f814340b9ddda707744d51.tar.bz2
gentoo-8fe0c6e7e883e0db58f814340b9ddda707744d51.zip
dev-python/parso-0.5.1-r1: revbump, port to new helpers, py38, pypy{,3}
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/parso')
-rw-r--r--dev-python/parso/parso-0.5.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/parso/parso-0.5.1-r1.ebuild b/dev-python/parso/parso-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..f5c44e291ec2
--- /dev/null
+++ b/dev-python/parso/parso-0.5.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="a python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="https://github.com/davidhalter/parso https://pypi.org/project/parso/"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest