summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Smirnov <civil@gentoo.org>2018-06-15 21:51:53 +0200
committerVladimir Smirnov <civil@gentoo.org>2018-06-15 21:51:53 +0200
commited5397f05159ac71b11914c12293c5cf94ef1419 (patch)
treea729838c06f05c1006fc9487db91d864a3d673e6 /dev-python/livereload
parentapp-emulation/qemu: rearrange patches (diff)
downloadgentoo-ed5397f05159ac71b11914c12293c5cf94ef1419.tar.gz
gentoo-ed5397f05159ac71b11914c12293c5cf94ef1419.tar.bz2
gentoo-ed5397f05159ac71b11914c12293c5cf94ef1419.zip
dev-python/livereload: Bump to 2.5.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/livereload')
-rw-r--r--dev-python/livereload/Manifest1
-rw-r--r--dev-python/livereload/livereload-2.5.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/livereload/Manifest b/dev-python/livereload/Manifest
index 27eb76253771..4947c94cbfb8 100644
--- a/dev-python/livereload/Manifest
+++ b/dev-python/livereload/Manifest
@@ -1 +1,2 @@
DIST livereload-2.4.1.tar.gz 25593 BLAKE2B 97a37349f14cb9d1841ec78cc3d1965b59f65f86b00cb972b9b726364f7f34e6409853f8af32215c6bd400698f9b3ac2b947ac7864a8df15ccec8badddaa0cfe SHA512 9106fe1894092ab336270f539be41d4db2d277560a41898e45014e34783ab0b601c993a5a5831c951d313db98ea835aecc8eb31468ba186e243a28df75bfe9bb
+DIST livereload-2.5.2.tar.gz 27070 BLAKE2B 9d2af1eb313f8fd6e7a5176565c3f7a9ab7d8a36260d568d47a427e14e8ed76c0edb0c227ba5784681c82d7c7b5994e151d14302d8c9d0e76caea7d12e130586 SHA512 bb4ba50a31a912051f6036754bfc6ce7ba33b1b8abd5a20ac151f996e347d84367d4cc26f9c798ed6aef487ea335e1591d40ebd1c12f9487f74992e53e129749
diff --git a/dev-python/livereload/livereload-2.5.2.ebuild b/dev-python/livereload/livereload-2.5.2.ebuild
new file mode 100644
index 000000000000..b4ef60096094
--- /dev/null
+++ b/dev-python/livereload/livereload-2.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python LiveReload is an awesome tool for web developers"
+HOMEPAGE="https://github.com/lepture/python-livereload"
+SRC_URI="https://github.com/lepture/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ ${CDEPEND}
+ dev-python/six[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+
+ distutils-r1_python_install_all
+}